Bug 81594

Summary: Computer constantly beeps after installing ethereal-gnome-0.9.8-0.73.0.i386.rpm
Product: [Retired] Red Hat Linux Reporter: Craig McCluskey <craigm>
Component: etherealAssignee: Phil Knirsch <pknirsch>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: rvokal, trevor
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-17 08:57:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Craig McCluskey 2003-01-10 22:51:02 UTC
After installing ethereal-0.9.8-0.73.0.i386.rpm and
ethereal-gnome-0.9.8-0.73.0.i386.rpm, any user who logs on gets a repetitive
beep from the computer.

This beeping, which goes on forever every couple of seconds (and was driving me
absolutely BATTY!), is because the following line is added at each beep to

File error: Permission denied, /usr/share/gnome/apps/Applications/Network

This occurs when ethereal-gnome-0.9.8-0.73.0.i386.rpm is installed because
the following file is installed:

-rw-r--r--    1 root    root              215 Dec 19 04:53

Since the directory /usr/share/gnome/apps/Applications/Network does not exist
before rpm installs the file ethereal.desktop, rpm creates the directory with
root's present umask. If that umask is 027 (as mine is!), the Network directory
is created as:

drwxr-x---    2 root         4096 Jan 10 10:52 Network

which is not readable by anyone but root.

This can be solved by adding creation of the directory to the RPM file:

drwxr-xr-x    2 root    root     0 Dec 19 09:05

Comment 1 Trevor Cordes 2003-01-17 08:44:55 UTC
Confirmed: I had the same problem and Craig's solution solved it.  Thanks!

Comment 2 Phil Knirsch 2003-01-17 08:57:44 UTC
OK, noted. I will check in newer ethereal versions if that problem still exists.
We probably won't rerelease the ethereal errata because of this though, as the
standard umask for root typically is 022, which will create world readable

Thanks for reporting it though.

Read ya, Phil