Bug 817

Summary: Gated cannot get multicast address assigned
Product: [Retired] Red Hat Linux Reporter: Daniel Senie <dts>
Component: gatedAssignee: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-15 15:50:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Senie 1999-01-13 16:21:28 UTC
Gated with ospf running fails to start. It looks like
multicast either isn't working at all on the platform, or
Gated is having trouble getting multicast enabled.

gated[6582]: task_set_option: task OSPF socket 7 option G
roupAdd(10) interface group
Operation not supported by device
gated[6582]: Abort gated[6582] version 3-5-10: Operation
not supported by device

Sample config which will cause this result:

rip off;

ospf on {
        backbone {
                interface eth0;

Note: using kernel off the 5.2 CDROMs. Have not tried with
updated kernels.

Comment 1 Jeff Johnson 1999-01-13 17:38:59 UTC
Could you try the gated from Raw Hide? (Do "rpm --rebuild
gated*.src.rpm"). Several problems were fixed in that version.

Multicast is enabled and working on i386/sparc (and I believe alpha).

Comment 2 Jeff Johnson 1999-01-14 19:13:59 UTC
I could not reproduce this problem using the example gated.conf
and the following packages

You might want to make sure that the ethernet driver that you are
using supports multicast.

Please reopen this bug if you have further information.

Comment 3 Daniel Senie 1999-01-14 19:22:59 UTC
Ethernet driver is tulip, definitely supports multicast.

Kernels tried are all stock kernels as delivered by RedHat. If your
build had it enabled, it's there.

I see problems on all systems I've tried with 5.2, with both XNTPD and
GATED. This is true on systems I've set up, and on those at some of my

I have not yet tried building a custom kernel to see if that would
solve the problem.

On the gated matter, one of my clients solved the problem by using the
gated from RHL 5.1 instead of the one from 5.2, and that ran OK. We
haven't run similar tests on XNTP yet.

Comment 4 Jeff Johnson 1999-01-14 21:11:59 UTC
FWIW; Red Hat currently uses multicast NTP to sync all our 5.2
machines. What happens if you ping

Comment 5 Daniel Senie 1999-01-14 21:29:59 UTC
Pings to do indeed result in ping responses from all hosts
which should be subscribed to the ALL-HOSTS multicast group. So, it
looks like multicast is there.

Could you send me sample ntp config files from your working machines?
I'll give them a try and see if they work here. The sample files, as
shipped, resulted in error messages related to multicast.

Comment 6 Daniel Senie 1999-01-15 05:20:59 UTC
I reopened a related bug on xntpd and added comments there. NTP will
indeed operate, despite a couple of error messages at startup.

Gated remains a problem, however. For now in the critical case, we're
using the gated RPM from 5.1, since that works (including multicast).
Seems like there's something specifically wrong with gated, or perhaps
it doesn't have the extra code xntpd has to work around the multicast
allocation problem reported in the xntpd error messages (if that's
indeed what xntpd is trying to say).

Comment 7 Jeff Johnson 1999-01-15 15:50:59 UTC
Please try the Raw Hide gated*src.rpm -- several problems have
been fixed there. You will need to do "rpm --rebuild gated*src.rpm"
in order to install since Raw Hide uses glibc-2.1.

Otherwise, since I can't reproduce the problem and have no further
information about how to reproduce the problem or even if a
problem still exists :-), I'm gonna close this.