This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 817072

Summary: python-2.7.3-3.fc17 FTBFS on ARM
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: pythonAssignee: Dave Malcolm <dmalcolm>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: dmalcolm, herrold, ivazqueznet, jonathansteffan, lmacken, mail, tomspur
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-2.7.3-6.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-05 13:40:18 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 245418    

Description Peter Robinson 2012-04-27 11:13:03 EDT
It's failing in a gdb test case for some reason

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=766235
Comment 1 Dave Malcolm 2012-04-30 12:33:02 EDT
For some reason test_gdb is failing every test case with:
AssertionError: 'warning: File "/builddir/build/BUILD/Python-2.7.3/build/debug/python-debug-gdb.py" auto-loading has been declined by your `auto-load safe-path\' set to "/usr".' != ''
Comment 2 Dave Malcolm 2012-04-30 12:40:29 EDT
Appears to relate to this patch set:
  http://sourceware.org/ml/gdb-patches/2012-03/msg00826.html
from which the workaround appears to be to add:
  'set auto-load safe-path'
to the commands invoked in each selftest.
Comment 3 Dave Malcolm 2012-04-30 12:42:43 EDT
For reference, this was with gdb.armv7hl 0:7.4.50.20120120-40.fc17
Comment 4 Dave Malcolm 2012-04-30 13:07:55 EDT
Candidate patch committed to git as:
http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commit;h=9261681cd04196e1c4370b4888c9dfeff2b19f66

Building python-2.7.3-5.fc18 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4035890
Comment 5 Dave Malcolm 2012-04-30 13:38:28 EDT
Build failed with:
  AssertionError: '"on" or "off" expected.' != ''
Comment 6 Dave Malcolm 2012-04-30 14:25:23 EDT
(In reply to comment #5)
> Build failed with:
>   AssertionError: '"on" or "off" expected.' != ''
This appears to be the error message for a gdb that doesn't understand "auto-load":
e.g. with GNU gdb (GDB) Fedora (7.3-43.fc15):
(gdb) set auto-load 
(gdb) set auto-load safe-path
"on" or "off" expected.
(gdb) set auto-load safe-path /
"on" or "off" expected.

Looks like F17's gdb has the patch, but rawhide doesn't.
Comment 7 Dave Malcolm 2012-04-30 16:27:29 EDT
It turns out that the gdb in git is more recent than that in the Koji
buildroots.  The updated gdb that has this feature is built into f17-candidate
and is available in updates-testing, but isn't yet in f17 or f18's buildroots for the primary architectures.

So this is a case where the secondary architectures are ahead of the primary architectures.

I've updated the patch to make it work with both old and new gdb builds (I
hope):
http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commit;h=1fa9c84f237d8822d26b9b229a4d68eed5b667c3

and am rebuilding into rawhide:
  Building python-2.7.3-6.fc18 for dist-rawhide
  Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4036938
Comment 8 Dave Malcolm 2012-04-30 17:28:23 EDT
(In reply to comment #7)
> and am rebuilding into rawhide:
>   Building python-2.7.3-6.fc18 for dist-rawhide
>   Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4036938
This built successfully into rawhide, and am building into f17:
   Building python-2.7.3-6.fc17 for f17-candidate
   Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4037025
and trying a scratch build for python3 (which presumably has the same issue).

Does this commit fix the build on ARM? (see the notes in comment #7; I did test the patch both with and without the new gdb feature, but the proof of the pudding is in the eating).
Comment 9 Peter Robinson 2012-04-30 17:56:18 EDT
Just submitted it as a new build http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=781730
Comment 10 Peter Robinson 2012-05-01 03:01:00 EDT
Confirmed that python-2.7.3-6.fc17 builds fine on ARM
Comment 11 Dave Malcolm 2012-05-01 11:47:10 EDT
(In reply to comment #8)
> This built successfully into rawhide, and am building into f17:
>    Building python-2.7.3-6.fc17 for f17-candidate
>    Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4037025
This build successfully

> and trying a scratch build for python3 (which presumably has the same issue).
and this scratch build also succeeded, so I've committed and pushed for python3 in master and f17, and am building non-scratch builds:
  Building python3-3.2.3-5.fc18 for dist-rawhide
  Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4040193

  Building python3-3.2.3-5.fc17 for f17-candidate
  Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4040195


> Does this commit fix the build on ARM? (see the notes in comment #7; I did test
> the patch both with and without the new gdb feature, but the proof of the
> pudding is in the eating).


(In reply to comment #10)
> Confirmed that python-2.7.3-6.fc17 builds fine on ARM

Thanks!

Closing this bug out, as I believe I don't need to do a Bodhi update for this, right?
Comment 12 Peter Robinson 2012-05-01 11:55:40 EDT
> Closing this bug out, as I believe I don't need to do a Bodhi update for this,
> right?

We need bodhi updates for F-17. We need the same builds tagged appropriately in mainline as for all secondary arches.
Comment 13 Dave Malcolm 2012-05-01 13:13:45 EDT
(In reply to comment #11)
>   Building python3-3.2.3-5.fc18 for dist-rawhide
>   Building python3-3.2.3-5.fc17 for f17-candidate
(both of these builds succeeded)
Comment 14 Fedora Update System 2012-05-01 13:19:38 EDT
python3-3.2.3-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-5785/python3-3.2.3-5.fc17
Comment 15 Fedora Update System 2012-05-01 13:27:30 EDT
python-2.7.3-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-2.7.3-6.fc17
Comment 16 Fedora Update System 2012-05-04 19:08:53 EDT
python-2.7.3-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-05-07 00:17:01 EDT
python3-3.2.3-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Luke Macken 2012-06-05 13:40:18 EDT
This looks like it is all set... closing.