Bug 81725

Summary: rpm -q dev --> error
Product: [Retired] Red Hat Raw Hide Reporter: Olivier Baudron <olivier.baudron>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED WORKSFORME QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-14 20:51:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Olivier Baudron 2003-01-13 13:24:39 UTC
$ rpm -q rpm
rpm-4.2-0.54

$ rpm -q dev
dev-3.3.2-1
error: db4 error(13) from db->close: Permission denied

Comment 1 Jeff Johnson 2003-01-13 15:43:44 UTC
I can't reproduce this. However, db-4.1.24 returns
errors from db-close. Harmless afaik, fix is gonna
be to not print the error message when the time comes.

Comment 2 Jeff Johnson 2003-01-13 15:43:56 UTC
I can't reproduce this. However, db-4.1.24 returns
errors from db->close. Harmless afaik, fix is gonna
be to not print the error message when the time comes.

Comment 3 Olivier Baudron 2003-01-13 16:32:39 UTC
The problem is not present with dev-3.3.1-3.
And you must 'rpm -q' as a normal user to see it.

Comment 4 Jeff Johnson 2003-01-14 20:51:54 UTC
Still WORKSFORME:

bash$ id                  
uid=2161(jbj) gid=2161(jbj) groups=2161(jbj)
bash$ rpm -q rpm dev
rpm-4.2-0.57
dev-3.3.2-1


Comment 5 Olivier Baudron 2003-01-16 12:22:47 UTC
This may be a db problem. I have db4-4.0.14-15 (rawhide and phoebe version) and
I could not find any db-4.1.24 package...

Comment 6 Jeff Johnson 2003-01-16 14:36:11 UTC
db-4.1.24 is internal to rpm sources.