This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 817555

Summary: mosh FTBFS on ARM
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: moshAssignee: Alex Chernyakhovsky <achernya>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: achernya
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-02 17:46:33 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 834447    
Bug Blocks: 245418    

Description Peter Robinson 2012-04-30 09:33:16 EDT
mosh-1.2-2.fc18

network.cc: In member function 'std::string Network::Packet::tostring(Crypto::Session*)':
network.cc:76:28: error: narrowing conversion of '({...})' from 'unsigned int' to 'uint16_t {aka short unsigned int}' inside { } is ill-formed in C++11 [-Werror=narrowing]
network.cc:76:50: error: narrowing conversion of '({...})' from 'unsigned int' to 'uint16_t {aka short unsigned int}' inside { } is ill-formed in C++11 [-Werror=narrowing]
cc1plus: all warnings being treated as errors
make[3]: *** [network.o] Error 1

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=780217
Comment 1 Alex Chernyakhovsky 2012-04-30 12:23:50 EDT
Hi,

I've talked with mosh upstream about this, and we're not entirely sure what's going on because mosh has been successfully built on Debian ARM.

Do you know if it is possible to get access to a Fedora Project ARM testing machine so that we can take care of this?
Comment 2 Peter Robinson 2012-06-17 06:30:35 EDT
> Do you know if it is possible to get access to a Fedora Project ARM testing
> machine so that we can take care of this?

Fedora doesn't generally have devices to provide remote access. Do you have access to any ARM based devices as it's not hard to boot a Fedora image off a SD card to get a Fedora ARM platform running.
Comment 3 Peter Robinson 2012-06-17 06:37:29 EDT
The actual failure is:

network.cc: In member function 'std::string Network::Packet::tostring(Crypto::Session*)':
network.cc:76:28: error: narrowing conversion of '({...})' from 'unsigned int' to 'uint16_t {aka short unsigned int}' inside { } is ill-formed in C++11 [-Werror=narrowing]
network.cc:76:50: error: narrowing conversion of '({...})' from 'unsigned int' to 'uint16_t {aka short unsigned int}' inside { } is ill-formed in C++11 [-Werror=narrowing]

So I'm not sure if that's a change in gcc 4.7.x as Debian I don't believe uses such a new version of gcc or because Fedora has tightens the build failure errors.
Comment 4 Alex Chernyakhovsky 2012-06-17 11:28:46 EDT
I'm expecting to receive a Raspberry Pi soon, but I suppose I could try extracting a Fedora image on one of my Android devices as a chroot.

I looked into the error and it appears to be a conflict between the glibc headers and C++11 automatic type promotion to avoid overflow, but I'll need to set up my ARM environment before I can verify.
Comment 5 Alex Chernyakhovsky 2012-06-21 18:04:48 EDT
We've traced the bug to an issue in glibc, http://sourceware.org/bugzilla/show_bug.cgi?id=12194.
Comment 6 Alex Chernyakhovsky 2012-06-21 18:06:39 EDT
Additionally, I've written a work-around patch and submitted it to upstream (https://github.com/keithw/mosh/pull/288) but I do not want to include it in the package yet as this is actually a glibc bug.
Comment 7 Peter Robinson 2012-07-02 17:46:33 EDT
This is now built in rawhide with the latest glibc in rawhide. We still don't have it built for F-17
Comment 8 Alex Chernyakhovsky 2012-10-19 18:44:44 EDT
Hi Peter,

Just wanted to let you know that I just uploaded mosh 1.2.3, which contains the workaround fixes, so it should now build on F17 as well.