This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 817697

Summary: ERROR with rpm_check_debug vs depsolve: libsmbios is needed by (installed) smbios-utils-bin-2.2.19-5.1.el4.i386
Product: Red Hat Enterprise Linux 5 Reporter: msinatl <msilverboard>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED NOTABUG QA Contact: BaseOS QE Security Team <qe-baseos-security>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 5.8   
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-01 14:44:09 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description msinatl 2012-04-30 18:58:38 EDT
Description of problem:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libsmbios is needed by (installed) smbios-utils-bin-2.2.19-5.1.el4.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 5.8 (Tikanga)
sudo yum --version
3.2.22
  Installed: rpm-4.4.2.3-28.el5_8.x86_64 at 2012-04-03 22:43
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2012-02-29 07:27
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-02-27 22:00

  Installed: yum-3.2.22-39.el5.noarch at 2012-02-22 17:51
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2011-11-29 20:13
  Committed: James Antill <jantill@redhat.com> at 2011-11-29 22:00

  Installed: yum-metadata-parser-1.1.2-3.el5.x86_64 at 2011-08-08 21:10
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2009-04-06 14:15
  Committed: James Antill <james.antill@redhat.com> at 2009-04-06 22:00

  Installed: yum-rhn-plugin-0.5.4-26.el5.noarch at 2012-02-22 17:51
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2011-10-06 12:01
  Committed: Michael Mraka <michael.mraka@redhat.com> at 2011-10-06 22:00


How reproducible:
I presume you would have to have a server at the same level as mine and run the exact same updates.

Steps to Reproduce:
sudo yum update
  
Actual results:
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package kernel.x86_64 0:2.6.18-308.4.1.el5 set to be installed
---> Package kernel-devel.x86_64 0:2.6.18-308.4.1.el5 set to be installed
---> Package kernel-headers.x86_64 0:2.6.18-308.4.1.el5 set to be updated
---> Package libsmbios.i386 0:2.2.26-3.el5 set to be updated
---> Package mysql.x86_64 0:5.5.23-1.el5.remi set to be updated
---> Package mysql-libs.x86_64 0:5.5.23-1.el5.remi set to be updated
---> Package mysql-server.x86_64 0:5.5.23-1.el5.remi set to be updated
---> Package php.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-cli.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-common.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-devel.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-gd.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-mbstring.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-mcrypt.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-mysql.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-pdo.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package php-pear.noarch 1:1.9.4-7.el5.remi set to be updated
---> Package php-xml.x86_64 0:5.3.11-1.el5.remi set to be updated
---> Package smbios-utils-bin.x86_64 0:2.2.26-3.el5 set to be updated
--> Processing Dependency: libsmbios.so.2()(64bit) for package: smbios-utils-bin
--> Processing Dependency: libsmbios_c.so.2()(64bit) for package: smbios-utils-bin
---> Package vsftpd.x86_64 0:2.0.5-24.el5_8.1 set to be updated
--> Running transaction check
---> Package libsmbios.x86_64 0:2.2.26-3.el5 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:2.6.18-274.18.1.el5 set to be erased
---> Package kernel-devel.x86_64 0:2.6.18-274.18.1.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch     Version               Repository              Size
================================================================================
Installing:
 kernel             x86_64   2.6.18-308.4.1.el5    rhel-x86_64-server-5    21 M
 kernel-devel       x86_64   2.6.18-308.4.1.el5    rhel-x86_64-server-5   5.7 M
Updating:
 kernel-headers     x86_64   2.6.18-308.4.1.el5    rhel-x86_64-server-5   1.4 M
 libsmbios          i386     2.2.26-3.el5          epel                   280 k
 mysql              x86_64   5.5.23-1.el5.remi     remi                   7.4 M
 mysql-libs         x86_64   5.5.23-1.el5.remi     remi                   1.1 M
 mysql-server       x86_64   5.5.23-1.el5.remi     remi                    13 M
 php                x86_64   5.3.11-1.el5.remi     remi                   2.8 M
 php-cli            x86_64   5.3.11-1.el5.remi     remi                   2.6 M
 php-common         x86_64   5.3.11-1.el5.remi     remi                   1.0 M
 php-devel          x86_64   5.3.11-1.el5.remi     remi                   2.6 M
 php-gd             x86_64   5.3.11-1.el5.remi     remi                   210 k
 php-mbstring       x86_64   5.3.11-1.el5.remi     remi                   2.3 M
 php-mcrypt         x86_64   5.3.11-1.el5.remi     remi                    49 k
 php-mysql          x86_64   5.3.11-1.el5.remi     remi                   173 k
 php-pdo            x86_64   5.3.11-1.el5.remi     remi                   121 k
 php-pear           noarch   1:1.9.4-7.el5.remi    remi                   437 k
 php-xml            x86_64   5.3.11-1.el5.remi     remi                   227 k
 smbios-utils-bin   x86_64   2.2.26-3.el5          epel                   111 k
 vsftpd             x86_64   2.0.5-24.el5_8.1      rhel-x86_64-server-5   142 k
Removing:
 kernel             x86_64   2.6.18-274.18.1.el5   installed               96 M
 kernel-devel       x86_64   2.6.18-274.18.1.el5   installed               16 M
Installing for dependencies:
 libsmbios          x86_64   2.2.26-3.el5          epel                   289 k

Transaction Summary
================================================================================
Install       3 Package(s)
Upgrade      18 Package(s)
Remove        2 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)

Total download size: 63 M
Is this ok [y/N]: y
Downloading Packages:
(1/21): php-mcrypt-5.3.11-1.el5.remi.x86_64.rpm          |  49 kB     00:00
(2/21): smbios-utils-bin-2.2.26-3.el5.x86_64.rpm         | 111 kB     00:00
(3/21): php-pdo-5.3.11-1.el5.remi.x86_64.rpm             | 121 kB     00:00
(4/21): vsftpd-2.0.5-24.el5_8.1.x86_64.rpm               | 142 kB     00:00
(5/21): php-mysql-5.3.11-1.el5.remi.x86_64.rpm           | 173 kB     00:00
(6/21): php-gd-5.3.11-1.el5.remi.x86_64.rpm              | 210 kB     00:02
(7/21): php-xml-5.3.11-1.el5.remi.x86_64.rpm             | 227 kB     00:00
(8/21): libsmbios-2.2.26-3.el5.i386.rpm                  | 280 kB     00:01
(9/21): libsmbios-2.2.26-3.el5.x86_64.rpm                | 289 kB     00:02
(10/21): php-pear-1.9.4-7.el5.remi.noarch.rpm            | 437 kB     00:06
(11/21): php-common-5.3.11-1.el5.remi.x86_64.rpm         | 1.0 MB     00:07
(12/21): mysql-libs-5.5.23-1.el5.remi.x86_64.rpm         | 1.1 MB     00:13
(13/21): kernel-headers-2.6.18-308.4.1.el5.x86_64.rpm    | 1.4 MB     00:05
(14/21): php-mbstring-5.3.11-1.el5.remi.x86_64.rpm       | 2.3 MB     00:34
(15/21): php-devel-5.3.11-1.el5.remi.x86_64.rpm          | 2.6 MB     00:24
(16/21): php-cli-5.3.11-1.el5.remi.x86_64.rpm            | 2.6 MB     01:29
(17/21): php-5.3.11-1.el5.remi.x86_64.rpm                | 2.8 MB     01:45
(18/21): kernel-devel-2.6.18-308.4.1.el5.x86_64.rpm      | 5.7 MB     00:27
(19/21): mysql-5.5.23-1.el5.remi.x86_64.rpm              | 7.4 MB     02:16
(20/21): mysql-server-5.5.23-1.el5.remi.x86_64.rpm       |  13 MB     05:23
(21/21): kernel-2.6.18-308.4.1.el5.x86_64.rpm            |  21 MB     01:35
--------------------------------------------------------------------------------
Total                                            71 kB/s |  63 MB     15:05
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libsmbios is needed by (installed) smbios-utils-bin-2.2.19-5.1.el4.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])


Expected results:
Same updates applied, but without the rpm_check_debug message?

Additional info:
Comment 1 James Antill 2012-05-01 14:44:09 EDT
Not sure what remi repo. is ... or all the packages you are replacing. You also seem to have an el4 package on a el5 machine (which is the problem).

Likely there is a pre-existing problem, try:

rpm -Va --nofiles --nodigest