Bug 818793

Summary: Weird warning output from 3.0
Product: [Community] Publican Reporter: Scott Mumford <smumford>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED NOTABUG QA Contact: Ruediger Landmann <rlandman>
Severity: low Docs Contact:
Priority: unspecified    
Version: 3.0CC: rlandman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-21 23:43:57 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Scott Mumford 2012-05-03 22:27:27 EDT
Description of problem:
When building documents using Publican 3.0, an obscure error message is output:

<code>
Use of uninitialized value $web_type in concatenation (.) or string at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 910, <FH> line 15.
	Using XML::LibXSLT on /usr/share/publican/xsl/html-pdf.xsl
</code>

This error message appears on all builds, but seems to have no effect on the build process at all.

Version-Release number of selected component (if applicable):
Publican 3.0

How reproducible:
100%

Steps to Reproduce:
1. Build book
2. Watch output
3. Hurr?
  
Actual results:
Either the error be more clear in what the problem is or, if it's unavoidable and harmless, it should make its way to /dev/null

Expected results:


Additional info: