Bug 819304

Summary: [abrt][reproducible] libreoffice-core-3.5.2.1-6.fc17: v killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Pavel Alexeev <pahan>
Component: libreofficeAssignee: David Tardon <dtardon>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:066ea3e4db48faaef973e5a80725b9adcecce8ce
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-22 10:16:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: event_log
none
File: backtrace
none
File: smolt_data
none
File: maps
none
File: dso_list
none
Rtf file to reproduce crash none

Description Pavel Alexeev 2012-05-06 08:00:32 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer '/home/pasha/temp/\xd0\x9f\xd0\xbe\xd1\x88\xd0\xb0\xd0\xb3\xd0\xbe\xd0\xb2\xd0\xb0\xd1\x8f \xd0\xb8\xd0\xbd\xd1\x81\xd1\x82\xd1\x80\xd1\x83\xd0\xba\xd1\x86\xd0\xb8\xd1\x8f \xd1\x83\xd1\x81\xd1\x82\xd0\xb0\xd0\xbd\xd0\xbe\xd0\xb2\xd0\xba\xd0\xb8 \xd0\x90\xd0\x98\xd0\xa1-\xd0\x98\xd0\x9c\xd0\xa3\xd0\xa1.rtf' --splash-pipe=6
crash_function: shared_ptr
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.3.4-3.fc17.x86_64
pid:            18120
pwd:            /home/pasha
remote_result:  NOTFOUND
time:           Вс. 06 мая 2012 15:20:17
uid:            1000
username:       pasha
xsession_errors: 

backtrace:      Text file, 106578 bytes
dso_list:       Text file, 22389 bytes
event_log:      Binary file, 5207 bytes
maps:           Text file, 96915 bytes
smolt_data:     Binary file, 3711 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/pasha/4

comment:
:Try open rtf file.
:Always reproducible.

core_backtrace:
:d0392284f9de7d89761971824e34bbeb14c0f959 0x6682f - libooxmllo.so -
:d0392284f9de7d89761971824e34bbeb14c0f959 0x4b939 writerfilter::dmapper::DomainMapper::lcl_text(unsigned libooxmllo.so -
:f471d3a6b7970585c73b48c20f8076eb8009806d 0x2c129 - librtftoklo.so -
:f471d3a6b7970585c73b48c20f8076eb8009806d 0x3f229 - librtftoklo.so -
:f471d3a6b7970585c73b48c20f8076eb8009806d 0x10dae - librtftoklo.so -
:4294fcedc5f570b8ea658cc1a4d3f9ac71ac2c64 0xa366 RtfFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> libwriterfilterlo.so -
:ae142b4c51d969f1e77767881edd96961bf8861a 0x2a152f SfxObjectShell::ImportFrom(SfxMedium&, libsfxlo.so -
:ae142b4c51d969f1e77767881edd96961bf8861a 0x2a5fc8 SfxObjectShell::DoLoad(SfxMedium*) libsfxlo.so -
:ae142b4c51d969f1e77767881edd96961bf8861a 0x2dff99 SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> libsfxlo.so -
:ae142b4c51d969f1e77767881edd96961bf8861a 0x313c70 - libsfxlo.so -
:cbe5378fe495f04a3e3153ce4c1f58202ff98671 0x10c4a3 - libfwklo.so -
:cbe5378fe495f04a3e3153ce4c1f58202ff98671 0x10d808 - libfwklo.so -
:cbe5378fe495f04a3e3153ce4c1f58202ff98671 0xa5b5e - libfwklo.so -
:cbe5378fe495f04a3e3153ce4c1f58202ff98671 0xa6088 - libfwklo.so -
:4a098fba4f41d80da4aaa21f0c49640f5ae6b1ad 0xd5ef4 comphelper::SynchronousDispatch::dispatch(com::sun::star::uno::Reference<com::sun::star::uno::XInterface> libcomphelpgcc3.so -
:8ed00f897a439ef3ff0a18b78944a1cc20c9a42c 0x334e7 - libsofficeapp.so -
:8ed00f897a439ef3ff0a18b78944a1cc20c9a42c 0x40fe1 - libsofficeapp.so -
:8ed00f897a439ef3ff0a18b78944a1cc20c9a42c 0x1fecf - libsofficeapp.so -
:8ed00f897a439ef3ff0a18b78944a1cc20c9a42c 0x210fc - libsofficeapp.so -
:f15ebc9a1da416bfcffa87b9d0b0bdae087a3b12 0x352a72 - libvcllo.so -
:f15ebc9a1da416bfcffa87b9d0b0bdae087a3b12 0x35c0b1 SalGenericDisplay::DispatchInternalEvent() libvcllo.so -
:76caf5a7b1cbce60b21b737f6f948f35cfc9b060 0xad74 - libvclplug_kde4lo.so -
:ccc0ca08220fabfc8aa9bdcd23c67d2db7514902 0x2b535 - libvclplug_genlo.so -
:ccc0ca08220fabfc8aa9bdcd23c67d2db7514902 0x2b05c SalXLib::Yield(bool, libvclplug_genlo.so -
:f15ebc9a1da416bfcffa87b9d0b0bdae087a3b12 0xfbb84 Application::Yield(bool) libvcllo.so -
:f15ebc9a1da416bfcffa87b9d0b0bdae087a3b12 0xfbc27 Application::Execute() libvcllo.so -
:8ed00f897a439ef3ff0a18b78944a1cc20c9a42c 0x1dd59 - libsofficeapp.so -
:f15ebc9a1da416bfcffa87b9d0b0bdae087a3b12 0x1025c1 - libvcllo.so -
:f15ebc9a1da416bfcffa87b9d0b0bdae087a3b12 0x102665 SVMain() libvcllo.so -
:8ed00f897a439ef3ff0a18b78944a1cc20c9a42c 0x41d26 soffice_main libsofficeapp.so -
:082db566f88565d68a364c4087a2c9464f14b0dd 0x6bb - [exe] -

environ:
:XDG_VTNR=2
:SSH_AGENT_PID=2368
:XDG_SESSION_ID=4
:'LESS_TERMCAP_mb=\x1b[01;31m'
:KDE_MULTIHEAD=false
:HOSTNAME=hubbitus
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:'LESS_TERMCAP_md=\x1b[01;31m'
:IMUS_HOME=/home/pasha/imus
:'LESS_TERMCAP_me=\x1b[0m'
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=hubbitus;1336303213;549700;2436_TIME0
:XDG_SESSION_COOKIE=91f3bb73516042ca0159a68e00000015-1336243643.603701-782967225
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/pasha/.gtkrc-2.0:/home/pasha/.gtkrc-2.0-kde4:/home/pasha/.kde/share/config/gtkrc-2.0
:GS_LIB=
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/pasha/.gtkrc:/home/pasha/.kde/share/config/gtkrc
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/pasha/keyring-91eZRU
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:'LESS_TERMCAP_ue=\x1b[0m'
:KDE_FULL_SESSION=true
:'IMSETTINGS_MODULE=X compose table'
:USER=pasha
:SSH_AUTH_SOCK=/tmp/ssh-xfDcNoru2246/agent.2246
:USERNAME=pasha
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2470,unix/unix:/tmp/.ICE-unix/2470
:'LESS_TERMCAP_us=\x1b[01;32m'
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/pasha/bin:/usr/sbin:/home/pasha/bin/php_templates:/home/pasha/bin:/usr/sbin:/home/pasha/bin/php_templates:/home/pasha/bin:/usr/sbin:/home/pasha/bin/php_templates
:DESKTOP_SESSION=kde-plasma
:MAIL=/var/spool/mail/pasha
:QT_IM_MODULE=xim
:PWD=/home/pasha
:XMODIFIERS=@im=none
:SVN=svn+ssh://x-www.info/mnt/sgtBarracuda/SVN_test/svn/repositories/
:EDITOR=mcedit
:KDE_SESSION_UID=1000
:GNOME_KEYRING_PID=2242
:LANG=ru_RU.UTF-8
:KDE_IS_PRELINKED=1
:GDM_LANG=ru_RU.UTF-8
:MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
:KDEDIRS=/usr
:LOADEDMODULES=
:GDMSESSION=kde-plasma
:HISTCONTROL=ignoreboth
:SSH_ASKPASS=/usr/bin/ksshaskpass
:XDG_SEAT=seat0
:HOME=/home/pasha
:SHLVL=2
:IMUS_MULE_2_1=/opt/mule-standalone-3.2.0
:MULE_BASE=/opt/mule-standalone-3.2.0
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=Adwaita
:SAL_ENABLE_FILE_LOCKING=1
:BASH_ENV=/home/pasha/.bashrc
:LOGNAME=pasha
:CVS_RSH=ssh
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pPbiX42h7h,guid=cea0ffec22c3c59282bab23d00000111
:'LESS_TERMCAP_so=\x1b[01;44;33m'
:MODULESHOME=/usr/share/Modules
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/pasha
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/pasha/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=xim
:XAUTHORITY=/tmp/kde-pasha/xauth-1000-_0
:'LESS_TERMCAP_se=\x1b[0m'
:'module=() {  eval `/usr/bin/modulecmd bash $*`\n}'
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 62117                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       62117                62117                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[27020]
:pos:	0
:flags:	00
:1:/home/pasha/.xsession-errors
:pos:	96220
:flags:	0102002
:2:/home/pasha/.xsession-errors
:pos:	96220
:flags:	0102002
:3:pipe:[485126]
:pos:	0
:flags:	02004000
:4:pipe:[485126]
:pos:	0
:flags:	02004001
:5:pipe:[489601]
:pos:	0
:flags:	00
:6:pipe:[489601]
:pos:	0
:flags:	01
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:pipe:[485127]
:pos:	0
:flags:	02004000
:9:pipe:[485127]
:pos:	0
:flags:	02004001
:10:socket:[485128]
:pos:	0
:flags:	02004002
:11:socket:[485129]
:pos:	0
:flags:	02004002
:12:socket:[485130]
:pos:	0
:flags:	02000002
:13:socket:[485134]
:pos:	0
:flags:	02000002

var_log_messages:
:May  6 15:20:16 hubbitus kernel: [11350.628137] soffice.bin[18120]: segfault at 1f0 ip 00007fe65428082f sp 00007fff83550e50 error 4 in libooxmllo.so[7fe65421a000+1c0000]
:May  6 15:20:18 hubbitus abrt[18131]: Saved core dump of pid 18120 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-05-06-15:20:17-18120 (88506368 bytes)
Comment 1 Pavel Alexeev 2012-05-06 08:00:40 EDT
Created attachment 582444 [details]
File: event_log
Comment 2 Pavel Alexeev 2012-05-06 08:00:42 EDT
Created attachment 582445 [details]
File: backtrace
Comment 3 Pavel Alexeev 2012-05-06 08:00:44 EDT
Created attachment 582446 [details]
File: smolt_data
Comment 4 Pavel Alexeev 2012-05-06 08:00:47 EDT
Created attachment 582447 [details]
File: maps
Comment 5 Pavel Alexeev 2012-05-06 08:00:49 EDT
Created attachment 582448 [details]
File: dso_list
Comment 6 David Tardon 2012-05-09 00:54:37 EDT
Could you attach the rtf file here?
Comment 7 Pavel Alexeev 2012-05-14 04:13:00 EDT
Created attachment 584283 [details]
Rtf file to reproduce crash

Off course
Comment 8 David Tardon 2012-05-14 05:39:36 EDT
reproducible
Comment 9 David Tardon 2012-05-14 06:47:57 EDT
Actually what _is_ broken is the producer of that file, because there is a \field group that is not terminated.
Comment 10 Pavel Alexeev 2012-05-16 13:17:41 EDT
(In reply to comment #9)
> Actually what _is_ broken is the producer of that file, because there is a
> \field group that is not terminated.
May be. I don't know. Despite it crash is not graceful error handling in any case :)
Comment 11 Caolan McNamara 2012-08-22 10:16:59 EDT
no crash in f-17 with libreoffice-3.5.6.2-1.fc17 anymore