Bug 819716

Summary: virsh cannot edit the guest xmlfile
Product: [Fedora] Fedora Reporter: Hongqing Yang <hoyang>
Component: libvirtAssignee: Michal Privoznik <mprivozn>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: berrange, clalancette, crobinso, dallan, dougsland, itamar, jforbes, jyang, laine, libvirt-maint, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-09 03:28:48 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hongqing Yang 2012-05-07 23:35:47 EDT
Description of problem:

create a guest 'f17' with virt-manager, then edit with 
virsh edit f17, and add the following into the xml file.
<channel type='tcp'>
  <source mode='connect' host='127.0.0.1' service='6080'/>
  <target type='virtio' name='org.fedoraproject.anaconda.log.0'/>
</channel>

after save it and open the guest xml file, it does not exist.

Version-Release number of selected component (if applicable):
0.9.6

How reproducible:


Steps to Reproduce:
1. create a guest
2. edit with 'virsh edit <machine name>'
3. save the edit and exit
4. nothing changed
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2012-05-09 03:28:48 EDT
I updated my system and tried again today, it works now with the same libvirt version 0.9.6. So I will close it as it it not a bug.