Bug 819839

Summary: Able to create Application blueprints with special characters
Product: CloudForms Cloud Engine Reporter: Rehana <redakkan>
Component: aeolus-conductorAssignee: Angus Thomas <athomas>
Status: CLOSED NOTABUG QA Contact: Rehana <aeolus-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 1.0.0CC: akarol, dajohnso, sshveta
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-25 11:13:10 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Rehana 2012-05-08 06:49:22 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to conductor
2.create application blueprints with name "reh@!#$#@$"
3.
  
Actual results:
Observed that user is allowed to create application blueprint with special characters

Expected results:
Should be validated

Additional info:
rpm -qa | grep aeolus
aeolus-conductor-0.8.13-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.13-1.el6_2.noarch
aeolus-conductor-doc-0.8.13-1.el6_2.noarch
aeolus-conductor-daemons-0.8.13-1.el6_2.noarch
Comment 2 Dave Johnson 2012-11-27 16:54:56 EST
*** Bug 833047 has been marked as a duplicate of this bug. ***
Comment 3 Dave Johnson 2012-11-27 16:55:01 EST
*** Bug 864220 has been marked as a duplicate of this bug. ***
Comment 4 Angus Thomas 2013-01-25 11:13:10 EST
Please repoen this if a specific problem caused by special characters is found.