Bug 820037

Summary: [ja_JP] [RHSM CLI] Import module - --help message some strings displayed as question mark.
Product: Red Hat Enterprise Linux 6 Reporter: Lijun Li <lijli>
Component: subscription-managerAssignee: Adrian Likins <alikins>
Status: CLOSED ERRATA QA Contact: Entitlement Bugs <entitlement-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 6.3CC: alikins, bkearney, eng-i18n-bugs, khong, lijli, qe-i18n-bugs
Target Milestone: rcKeywords: i18n, Translation
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 773537 Environment:
Last Closed: 2012-06-20 08:57:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 773537    
Bug Blocks: 738066    

Description Lijun Li 2012-05-08 20:30:29 EDT
It's reproduced on subscription-manager-0.99.16-1.el6.x86_64.

+++ This bug was initially created as a clone of Bug #773537 +++

Description of problem:
Import module - --help message some strings displayed as question mark.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install rhel5.8 snapshot-3 OS build via

2. (Display help)

$ sudo subscription-manager import --help

Actual results:
Import module - --help message some strings displayed as question mark.

Expected results:
All the strings should be displayed correctly.

Additional info:

--- Additional comment from lijli@redhat.com on 2012-01-12 02:52:37 EST ---

Created attachment 552331 [details]
Strings displayed as question mark
Comment 2 Adrian Likins 2012-05-10 10:37:52 EDT
commit aa2020706aedac193f5f869f16610c43694ac3c5
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed May 9 11:39:29 2012 -0400

    820040,820037,820030: don't break multibyte help blurbs
    Add a optparse.HelpFormatter subclass that includes
    a version of format_option that does not try to split
    long words.This behavior is broken for multibyte cases.
    This includes code cut&paste from optparse.py in
    the python dist.

Should show up in 0.99.18
Comment 6 Lijun Li 2012-05-18 03:14:38 EDT
Verified, it's fixed on subscription-manager-0.99.18-1.el6.x86_64.
Comment 8 errata-xmlrpc 2012-06-20 08:57:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.