Bug 820323

Summary: [abrt] kernel: WARNING: at drivers/gpu/drm/i915/i915_drv.c:413 __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]()
Product: [Fedora] Fedora Reporter: sheepdestroyer
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: ajax, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:daf7511d4f8c63916000e48c91b18942f2b97a77
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-29 13:55:13 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description sheepdestroyer 2012-05-09 11:57:24 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.4-3.fc16.x86_64 root=UUID=86b623a1-afb5-4afb-b1c2-d90ccd6c62e4 ro quiet rhgb pcie_aspm=force i915.i915_enable_rc6=1 i915.semaphores=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=jp106
kernel:         3.3.4-3.fc16.x86_64
reason:         WARNING: at drivers/gpu/drm/i915/i915_drv.c:413 __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]()
time:           Thu 10 May 2012 12:56:03 AM JST

backtrace:
:WARNING: at drivers/gpu/drm/i915/i915_drv.c:413 __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]()
:Hardware name: 4286CTO
:Modules linked in: tcp_lp ppdev parport_pc lp parport nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ebtable_nat ebtables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM libcxgbi cxgb3 mdio iptable_mangle ib_iser fcoe bridge rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp lockd libfcoe libfc libiscsi_tcp 8021q garp stp llc scsi_transport_fc libiscsi scsi_tgt scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ip6table_filter nf_conntrack ip6_tables input_polldev snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq arc4 vhost_net macvtap macvlan snd_seq_device iwlwifi tun snd_pcm thinkpad_acpi tpm_tis tpm virtio_net i2c_i801 snd_timer iTCO_wdt hi
:d_logitech_dj tpm_bios microcode snd snd_page_alloc kvm_intel mac80211 e1000e cfg80211 sunrpc rfkill iTCO_vendor_support kvm binfmt_misc soundcore sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1213, comm: X Tainted: G        W    3.3.4-3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81057abf>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057b1a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa0077904>] __gen6_gt_wait_for_fifo+0x94/0xa0 [i915]
: [<ffffffffa0077fea>] i915_write32+0x5a/0xd0 [i915]
: [<ffffffffa00b56bc>] gen6_ring_get_irq+0x9c/0xc0 [i915]
: [<ffffffffa00b5738>] gen6_render_ring_get_irq+0x18/0x20 [i915]
: [<ffffffffa0088e83>] i915_wait_request+0x183/0x520 [i915]
: [<ffffffff8107a7f0>] ? remove_wait_queue+0x50/0x50
: [<ffffffffa0089252>] i915_gem_object_wait_rendering+0x32/0x40 [i915]
: [<ffffffffa008ab70>] i915_gem_object_set_to_gtt_domain+0xd0/0x1e0 [i915]
: [<ffffffffa008eca3>] i915_gem_execbuffer_relocate_entry+0x133/0x300 [i915]
: [<ffffffffa00901b6>] i915_gem_do_execbuffer+0x1276/0x1640 [i915]
: [<ffffffffa0090a49>] i915_gem_execbuffer2+0xa9/0x260 [i915]
: [<ffffffffa0022464>] drm_ioctl+0x444/0x510 [drm]
: [<ffffffffa00909a0>] ? i915_gem_execbuffer+0x420/0x420 [i915]
: [<ffffffff8126bf90>] ? inode_has_perm+0x30/0x40
: [<ffffffff8126f22c>] ? file_has_perm+0xdc/0xf0
: [<ffffffff81192f98>] do_vfs_ioctl+0x98/0x550
: [<ffffffff811934e1>] sys_ioctl+0x91/0xa0
: [<ffffffff815fc187>] ? int_check_syscall_exit_work+0x34/0x3d
: [<ffffffff815fbee9>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 60231598-704c-49e6-99da-3a66b54620b2
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5382.27
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2701
:System Memory: 3732
:System Swap: 5855
:Vendor: LENOVO
:System: 4286CTO ThinkPad X220
:Form factor: Notebook
:Kernel: 3.3.4-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8666) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4147:404:6058:8666) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:294:6058:8666) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7171:6058:8666) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7184:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7192:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8666) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7202:6058:8666) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(4480:59427:6058:8666) pci, sdhci-pci, BASE, N/A
:(32902:7213:6058:8666) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8666) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8666) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8666) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda7 / ext4 4096 4096 10648959 2754467 2647888 2670592 2352928 2352928
:/dev/sda5 /boot ext4 1024 1024 508745 350558 324958 128016 127632 127632
:
Comment 1 Dave Jones 2012-05-10 11:10:13 EDT
*** Bug 820324 has been marked as a duplicate of this bug. ***
Comment 2 Adam Jackson 2012-08-29 13:55:13 EDT

*** This bug has been marked as a duplicate of bug 772364 ***