Bug 82097

Summary: swedish "nodeadkeys" keymap variant has tilde as a dead key
Product: [Retired] Red Hat Public Beta Reporter: Henrik Nordstrom <hno>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: pawsa
Target Milestone: ---Keywords: MoveUpstream
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-24 15:42:42 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Henrik Nordstrom 2003-01-17 09:12:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
swedish "nodeakeys" keymap variant has tilde as a dead key

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setxkbmap se nodeadkeys
2. press "Alt-Gr Tilde" (keycode 35) to produce a tilde
3.

Actual Results:  Dead key. xev shows "dead_tilde"



Expected Results:  A tilde

Additional info:

The "dead_tilde" key does not seem to work either. dead_tilde a should produce a
 "a with tilde"


xev output:

KeyPress event, serial 25, synthetic NO, window 0x3200001,
    root 0x40, subw 0x0, time 54495078, (105,69), root:(135,201),
    state 0x80, keycode 35 (keysym 0xfe53, dead_tilde), same_screen YES,
    XLookupString gives 1 bytes:  "~"



I am using the XFree86-4.2.99.3-20021230.4 RadHide package due to other problems
with the swedish keyboard layout in the default Phoebe XFree86 package.
Comment 1 Henrik Nordstrom 2003-01-17 12:18:52 EST
Minor Correction: The dead_tilde does indeed work fine as a dead key, so it is
only the fact that it is a dead key in the keymap without dead keys that is the
bug here..
Comment 2 Henrik Nordstrom 2003-01-17 12:48:28 EST
This kombined with Bug #80922 causes some grief for me.. but I can remap the key
for now so I will surive.
Comment 3 Mike A. Harris 2003-01-21 05:58:51 EST
This is reported as working properly in rawhide.  If you upgrade to the latest
packages in rawhide and the problem persists, please report the issue directly
to xfree86@xfree86.org, and reopen this bug report so we can track it.

Thanks.
Comment 4 Henrik Nordstrom 2003-01-21 13:34:00 EST
Upgraded to XFree86-4.2.99.3-20030115.0 and the problem persists.

Bug #80922 also still seems to exists (deadkey->space not producing the ascii
version of the dead symbol), but now I noticed it at least works in the gdm
login screen.

I have sent a XFree86 bug report for this issue.
Comment 5 Henrik Nordstrom 2003-01-21 14:34:43 EST
Digged around a little and found how to fix this.

This small patch fixes the tilde key in the swedish nodeadkeys keymap issue
recently reported to XFree86@xfree86.org.

Regards
Henrik Nordström


--- XFree86-4.2.99.3/xc/programs/xkbcomp/symbols/pc/se  2002-12-19
02:07:56.000000000 +0100
+++ /usr/lib/X11/xkb/symbols/pc/se      2003-01-21 20:11:05.000000000 +0100
@@ -39,7 +39,7 @@
     include "pc/se(basic)"
 
     key <AE12> { [     acute,      grave ]     };
-    key <AD12> { [ diaeresis, asciicircum ]    };
+    key <AD12> { [ diaeresis, asciicircum, asciitilde ]        };
     key <AB08> { [     comma,  semicolon,      cedilla,       ogonek ] };
     key <AB09> { [    period,      colon, periodcentered,   abovedot ] };
 


Posted to XFree86.
Comment 6 Henrik Nordstrom 2003-01-21 15:12:40 EST
Received a response from what seems to be the maintainer of the xkb keymaps and
his patch works (but maybe a little too good.. it completely removes all dead
keys, not only the keys printed on the keyboard).

I would think it is safe to assume this will be fixed in the next XFree86
snapshot (4.2.99.5 I suppose).


Copy of received message:

On Tue, Jan 21, 2003 at 10:29:35AM -0800, Henrik Nordstrom wrote:
>Regarding: tilde registered as a dead key in swedish nodeadkeys keymap
>Email: xfree86@hno.marasystems.com
>------------------------------------------------------------
>XFree86 Version: XFree86 Version 4.2.99.3 (Red Hat Linux release:
4.2.99.3-20030115.0) / X Window System
>
>OS: RedHat rawhide
>
>Area: Xserver
>
>Server: XFree86 (The XFree86 4.x server)
>
>Description:
>
>While using the swedish(se) nodeadkeys keymap AltGR + "diaresis/circum/tilde"
key (keycode 35) produces a "dead_tilde" keycode instead of the expected and
wanted "asciitilde" keycode.
>
>Note: Have also found a "dead_diaresis" on AltGR+aring key (keycode 34). Not
that this one hurts but is slightly unexpected.
>
>Repeat By:
>
>% setxkbmap se nodeadkeys
>
>Try to type a tilde by pressing AltGR + "diaresis/circum/tilde" key.

Try the attached patch.  It should map the non-dead versions (where
possible) for the 'se' nodeadkeys map.  If this looks OK, it can
be used as a basis for fixing the nodeadkeys version of the other
maps too.

What should the mapping for the aring key be?

David
-- 
David Dawes
Release Engineer/Architect                      The XFree86 Project
www.XFree86.org/~dawes
Comment 7 Pawel Salek 2003-01-22 16:40:28 EST
A probably related problem with XFree86-4.2.99.3-20030115.0 and following 
configuration:
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "se"
I cannot get 'at' character (Usually alt+2) and the key that usually produces
tilde gives two dots instead (as in ä).
Comment 8 Henrik Nordstrom 2003-01-22 19:27:56 EST
Works here.. but then I am using the nodeadkeys variant and my se keymap slighty
patched to support non-dead tilde key with the patch seen on
XFree86@Xfree86.org.. but I cannot see there should be a difference.

What does xev report for the keys in question?

Note: There is difference in Alt (left) and AltGr (right). Only AltGr can be
used as "shift" key for accessing the extra keysyms on keys. The left Alt key is
used for special commands and shortcuts only, and will give the same symbol as
if no shift/altgr key is used if there is no shortcut bound to the key.


Also note that until Bug #80922 is fixed typing tilde (or backquote) in the
standard se keymap with dead keys might be a little troublesome.. but that is
another story.
Comment 9 Pawel Salek 2003-01-23 02:19:14 EST
The key in question generates dead_diaersis, dead_circumflex (with shift) and
dead_diaersis (with AltGr which generates Mode_switch).
Comment 10 Mike A. Harris 2003-01-23 04:12:00 EST
* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 4.2.99.4-20030121.1
- Added XFree86-4.2.99.4-xkb-se-asciitilde.patch to fix (#80922,82097)
Comment 11 Henrik Nordstrom 2003-01-23 04:51:45 EST
Which is entirely correct for the normal swedish keymap with dead keys.



Mike: Did you add the patch from David Hawes complete patch which introduces a
nodeadkeys framework all the latin based keymaps can use (but only se(nodeadkes)
make use of yet in the patch) or my simpler patch which only addresses the tilde?


I think you should be using the complete patch. Simplar changes as those made in
the se map should also be done in other national keymaps based on latin to
provide correct nodeadkeys versions (see Davids patch on the XFree86 mailinglist
for details)
Comment 12 Mike A. Harris 2003-01-23 23:57:31 EST
>Mike: Did you add the patch from David Hawes complete patch which introduces a
>nodeadkeys framework all the latin based keymaps can use (but only se(nodeadkes)
>make use of yet in the patch) or my simpler patch which only addresses the tilde?

s/Hawes/Dawes/

No, I have not seen such a patch.  If you attach it as a proper bugzilla
file attachment however I will investigate it.

>I think you should be using the complete patch. Simplar changes as those
>made in the se map should also be done in other national keymaps based
>on latin to provide correct nodeadkeys versions (see Davids patch on
>the XFree86 mailinglist for details)

Again, I haven't seen the patch.  If David believes it is correct, he will
commit it to CVS.  Feel free to attach it as type text/plain below however.



Comment 13 Mike A. Harris 2003-01-24 09:06:12 EST
I found David's patch and applied it to a local build.

Please test:

* Fri Jan 24 2003 Mike A. Harris <mharris@redhat.com> 4.2.99.4-20030121.2
- Added more complete XFree86-4.2.99.4xkb-se-fix.patch from David Dawes to
  replace XFree86-4.2.99.4-xkb-se-asciitilde.patch if it works properly

Comment 14 Henrik Nordstrom 2003-01-24 09:48:45 EST
Where can this local build be found for testing?
Comment 15 Mike A. Harris 2003-01-24 15:42:42 EST
Monitor rawhide.  When it get's pushed publically, you'll be able to
download it.