Bug 821180

Summary: Nouveau driver blank screens when KMS kicks in on Nvidia Geforce GTX 460 v2
Product: [Fedora] Fedora Reporter: Luya Tshimbalanga <luya>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 17CC: airlied, ajax, awilliam, bskeggs, dsmithjr, hades2k5, usdanskys
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: 1.0.1-6.fc18 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-12 15:17:20 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
kernel logs with drm.debug=14 from loading nouveau driver with modeset=1 on the affected system
Pictures of booting Fedora 18 Alpha none

Description Luya Tshimbalanga 2012-05-12 16:28:34 EDT
Description of problem:
Anaconda is unable to detect the system equipped with Nvidia Geforce GTX 460 v2 and use nouveau. The result is a black screen

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Choose a default installation on Fedora 17 beta and later.
Actual results:
A black screen

Expected results:
Nouveau driver should recognize Geforce GTX 460 v2

Additional info:
Here is an information about Geforce GTX 460v2:

According to nouveau driver website:

Geforce GTX 460v2 belong to NVCE (GF114) which should be detected but was not. For that reason, I cannot provide xorg report.
Comment 1 Greg` 2012-05-12 18:42:07 EDT
i get the same problem as Luya, but my card is a Geforce 550ti card . Fedora16 works fine though
Comment 2 Adam Williamson 2012-05-14 19:53:45 EDT
Luya: Do you actually have any basis for your assumption that nouveau isn't being used? If all you see is a black screen, I don't see that you can know for sure whether nouveau is being used and failing, or nouveau is not being used and the fallback driver is failing.

anaconda doesn't do any kind of detection in itself, it simply relies on X detection.

do you see the same problem if you boot a live image? how about if you explicitly choose the 'basic graphics mode' option for the DVD or a live image?

Fedora Bugzappers volunteer triage team
Comment 3 Greg` 2012-05-14 20:17:09 EDT
only way for me to be able to install F17 and thats to use xdriver=vesa nomodeset . Nouveau just wont work. which would mean i'd have to install the blob nvidia driver soon afterwards. 

i think Luya means Nouveau Adam, not Anaconda. 

i'd happily send n a xorg report but i cannot get one either an im to lazy to be bothered getting it :D i can get to a console but i have no idea what else to do.
Comment 4 Adam Williamson 2012-05-14 20:22:24 EDT
Greg: your adapter is not the same as Luya's, and therefore you are unlikely to be experiencing the same bug. Please file a new one. Thanks!

Fedora Bugzappers volunteer triage team
Comment 5 Luya Tshimbalanga 2012-05-14 20:26:33 EDT
Yes, it is nouveau driver.

I fully reproduced the problem with either F17 Beta DVD and Live image built on May 07 to confirm my assumption about the brokeness of nouveau driver. After the initialization, only black screen for more than 10 minutes in extreme case. Even using F17 as rescue media is affected by the same problem. For those reasons, I had to use 'basic graphic mode' option as work around.

F16 media is not affected by this issue.
Comment 6 Greg` 2012-05-14 20:33:10 EDT
mines the same problem might not be the same adapter but its the same problem IMO . as Luya has said, F16 is not effected , which i can get to work without a problem.
Comment 7 Adam Williamson 2012-05-14 20:34:14 EDT
OK, so the point is that the nouveau driver is not working with your card. detection is not the problem.

we will need to get some logs out, one way or another. Tim did suggest one way on the mailing list.

Fedora Bugzappers volunteer triage team
Comment 8 Adam Williamson 2012-05-14 20:35:02 EDT
greg: the symptom is very general. i've seen hundreds of completely different bugs manifest as 'X doesn't start up properly'. unless you get logs pointing to the same cause, the natural assumption with two different adapters is that the cause is different.
Comment 9 Luya Tshimbalanga 2012-05-14 21:08:42 EDT
I just tried Tim's suggestion. I cannot retrieve the log from my desktop using
my laptop because of refused connection.
For example:
 vmlinuz init  root sshd

 I might miss something...
Comment 10 Adam Williamson 2012-05-15 16:44:01 EDT
OK, so we finally managed to get some debug logs out of Luya's system.

It seems that if you just boot anaconda regularly with the sshd parameter, the nouveau failure is sufficiently serious that anaconda never makes it to the point of starting up the sshd service - i.e. the nouveau failure crashes anaconda, crashes the whole system, or prevents the user seeing some dialog that needs to be dismissed before sshd starts up.

However, by booting with 'nomodeset text sshd', sshing in, *then* switching to a VT and doing 'modprobe -r nouveau' followed by 'modprobe nouveau modeset=1', we were able to get this log.

Fedora Bugzappers volunteer triage team
Comment 11 Adam Williamson 2012-05-15 16:44:20 EDT
oh, we also included drm.debug=14 in the kernel parameters.
Comment 12 Adam Williamson 2012-05-15 16:45:21 EDT
Created attachment 584788 [details]
kernel logs with drm.debug=14 from loading nouveau driver with modeset=1 on the affected system

When loading the module this way, the system keeps running, but the display seems to be permanently dead until reboot. The monitor is stuck in power-saving mode.
Comment 13 Adam Williamson 2012-05-15 16:46:02 EDT
The adapter in question is a "02:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:1205] (rev a1)" according to lspci -nn.
Comment 14 Adam Williamson 2012-05-15 16:46:57 EDT
nouveau.noaccel=1 did not help this failure, BTW. Luya says it works fine with F16.
Comment 15 Steven Usdansky 2012-05-28 14:02:55 EDT
Recognizing that it might not actually be the same bug, I'm seeing the same symptoms (nouveau just locks the system on F17 TC6, F16 just works) on my system - onboard nVidia Corporation C51 [GeForce 6150 LE] (rev a2). Will check out whatever fixes this bug and file a new bug report if my system still has problems
Comment 16 Steven Usdansky 2012-05-28 20:24:30 EDT
More detail - no doubt relevant. The working F16 version is i686. The non-working F17 TC6 version (both installed and live) is x86_64. F17 TC6 i686 works properly from the live CD.
Comment 17 giovanni 2012-05-31 08:27:36 EDT
I have the same problem. My card is GeForce 9800GT.

I see a blank screen and also the mouse pointer. In Alt-F2 i can see the log that shows anaconda is waiting for language selection. If i back to Alt-F6 (i think) again, only appears the blank screen and the mouse pointer
Comment 18 Dave 2012-06-02 17:29:03 EDT
I don't know if I can be of any help or not, but I have the same issue.

Fedora17 x86-64 live USB doesn't work - just black screens that go into power saving mode.  My Ubuntu 12.04 installation wasn't working either but I was able to get it up and running by installing the Nvidia driver via basic grahpics mode.  I don't currently have Fedora installed on this machine so I'm just stuck with the blank screens.

My graphics card is the Nvidia GTX 460 v2.
Comment 19 Luya Tshimbalanga 2012-07-22 23:03:19 EDT
Any progress about the issue. I still have the issue with the card and had to use rpmfusion Nvvidia driver in a meanwhile.
Comment 20 Luya Tshimbalanga 2012-09-04 20:46:15 EDT
Running x86 Fedora 18 Desktop build 20120901. The system booted into failed save mode, the rendering is messy. The bug is still present on Fedora 18 and rawhide let alone F17.
Comment 21 Luya Tshimbalanga 2012-09-19 03:31:11 EDT
Created attachment 614224 [details]
Pictures of booting Fedora 18 Alpha

Here is screenshot of desktop running Fedora 18 Alpha Live edition. drm from nouveau driver failed to load Geforce GTX 460 v2 hence the fallback mode from plymouth and will keep looping until I reboot. I had to resort to VESA mode to boot to the desktop which is unstable. Nvidia driver packaged by RPM Fusion is not affected which I use on Fedora 17 since the submission of bug report.
Comment 22 Luya Tshimbalanga 2012-09-25 18:22:22 EDT
Using test-day 20120924 live usb, nouveau driver now fully works on Nvidia Geforce GTX 460 v2. Version is 1.0.1-6.fc18. It would be nice if that fix is backported for F17.
Comment 23 Luya Tshimbalanga 2013-01-12 15:17:20 EST
Latest version on driver 1.0.3-1.fc18 runs Nvidia Geforce 460 v2 smoothly. The issue no longer occurs and I can close this bug. Thanks to all participants.