Bug 821272

Summary: Powermac G5 w/ nVidia 7800 GT freezes after initial boot from F18 PPC64/beta DVD
Product: [Fedora] Fedora Reporter: Ronald Maas <rmaas>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: frenchja, gansalmon, itamar, jforbes, jonathan, kernel-maint, madhu.chinakonda, pknirsch
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-01 12:08:19 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ronald Maas 2012-05-13 14:52:53 EDT
Description of problem:
Powermac G5 freezes after displaying the following information on the screen. 
Fans start blowing.
Need to press power button to restart the computer.

Last screen:
[   0.000000]     0: 0x00010000 -> 0x0001a000
CF000015

Setup Done
[   0.000000] [boot]0015 Setup Done
[   0.000000] PERCPU: Embedded 2 pages/cpu @c0000000003050000 s84608 r0 d46464 u131072
[   0.000000] Built 1 zonelists in Node order, mobility grouping on. Total pages: 73637
[   0.000000] Policy zone: DMA
[   0.000000] Kernel command line: ro root=live:CDLABEL=Fedora_17_ppc64
[   0.000000] PID hash table entries: 4096 (order: -1, 32768 bytes)
[   0.000000] freeing bootmem node 0
[   0.000000] Memory: 4519680k/4718592k available (17920k kernel code, 198912k reserved, 1856k data, 2952k bss 6656k init)
[   0.000000] SLUB: Genslabs=19, HWalign=128, Order=0-3, MinObjects=0, CPUs=2, Nodes=256
[   0.000000] Hierarchical RCU umplementation.
[   0.000000] NR_IRQS:512 nr_irqs:512 16
[   0.000000] mpic: Setting up MPIC " MPIC 1   " version 1.2 at f8040000, max 2 CPUs
[   0.000000] mpic: ISU size: 124, shift: 7, mask: 7f
[   0.000000] mpic: Initializaing for 124 resources
[   0.000000] mpic: Setting up HT PICs workarounds for U3/U4
[   0.000000] mpic:   - HT:07.0 [0x90] vendor 106b device 0053 has 86 irqs
[   0.000000] clocksource: timebase mult[1e000005] sift[24] registered
[   0.000000] Console: colour dummy device 80x25
[   0.000000] console [tty0] enabled, bootconsole disabled
smp_core99_probe
smp_core99_kick_cpu
smp_core99_kick_cpu done
smp_core99_bringup_done

[   0.000000] PCI host bridge /pci@0,f0000000  ranges:
[   0.000000]  MEM 0x00000000f1000000..0x00000000f1ffffff -> 0x00000000f1000000
[   0.000000]   IO 0x00000000f0000000..0x00000000f07fffff -> 0x0000000000000000
[   0.000000]  MEM 0x0000000090000000..0x00000000afffffff -> 0x0000000090000000
[   0.000000] Can't get bus-range for /ht@0,f2000000, assume bus 0
[   0.000000] Found U3-GT PCI host bridge. Firmware bus number: 0->239
[   0.000000] PCI host bridge /ht@0,f2000000 (primary ranges:
[   0.000000] SMU: Driver 0.7 (c) 2005 Benjamin Herrenschmidt, IBM Corp.
[   0.000000] nvram: Checking bank 0...
[   0.000000] nvram: gen0=268, gen1=269
[   0.000000] nvram: Active bank is: 1
[   0.000000] nvram: OF partition at 0x410
[   0.000000] nvram: XP partition at 0x1020
[   0.000000] nvram: NR partition at 0x1120
[   0.000000] Zone PFM ranges:
[   0.000000]   DMA      0x0000000 -> 0x0001a000
[   0.000000]   Normal   empty
[   0.000000] Movable zone start PFM for each node
[   0.000000] Early memory PFM ranges
[   0.000000]     0: 0x00000000 -> 0x00008000

Version-Release number of selected component (if applicable):
Fedora 17 PPC64/beta DVD

How reproducible:
Every time

Steps to Reproduce:
1. Insert Fedora 17 beta DVD in 
2. Reboot
3. Press C after chime
4. Press <enter> on boot: prompt
  
Actual results:
Computer freezes during inital boot of Linux kernel

Expected results:
First Anaconda screen

Additional info:
Powermac G5 (late 2005)
Dual core 2 GHz
4.25 GB RAM
500 MB SATA
nVidia 7800 GT

Actions done to solve the issue:
- checked SHA256 checksums for downloaded ISOs
- checked for burning errors
- Specified kernel flags: text video=ofonly
Comment 1 Ronald Maas 2012-07-01 21:33:16 EDT
Issue is also reproducable with Fedora 17 (final) DVD

Additional actions done:
- Run installer from Fedora 17 (final) Boot CD
- Tried to boot installer with following kernel flags:
  nouveau.modeset=0
  nouveau.noaccel=1
  vnc
- Swapped hard drives
- Used different DDR2 RAM modules
- Changed jumper on Superdrive from C/S => Master

Unfortunately none of these actions solved the issue
Comment 2 Justin M. Forbes 2012-12-07 11:40:51 EST
Is this still happening with 3.6.9 kernels or the F18 beta disk?
Comment 3 Ronald Maas 2012-12-08 01:00:20 EST
Issue is not resolved. When I boot the G5 with the F18 beta DVD, the following is displayed on screen:

[    0.000000] DART table allocated at: c00000007f000000
[    0.000000] Using PowerMac machine description
[    0.000000] Found initrd at 0xc00000000188000:0xc000000031e8060
[    0.000000] Found U4 memory controller & host bridge @ 0xF8000000 revision 0x42
[    0.000000] Mapped at 0xd000080080000000
[    0.000000] Found a Shasta mac-io controller, rev: 0, mapped at 0xd000080080050000
[    0.000000] PowerMac motherboard: PowerMac G5 Dual Core
[    0.000000] DART IOMMU initialized for U4 type chipset
[    0.000000] bootconsole [udbg0] enabled
[    0.000000] CPU maps initialized for 1 thread per core
[    0.000000] Starting Linux PPC64 #1 SMP Fri Nov 9 11:20:36 MST 2012
[    0.000000] -----------------------------------------------------
[    0.000000] ppc64_pft_size                = 0x0
[    0.000000] physicalMemorySize            = 0x120000000
[    0.000000] htab_address                  = 0xc000000198000000
[    0.000000] htab_hash_mask                = 0xfffff
[    0.000000] -----------------------------------------------------
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.6.6-3.fc18.ppc64 (mockbuild@) (gcc version 4.7.2 20121001 (Red Hat 4.7.2-3) (GCC) ) #1 SMP Fri Nov 9 11:20:36 MST 2012
CF000012

Setup Arch
[    0.000000] [boot]0012 Setup Arch
[    0.000000] Segment table for CPU 1 at 0xc00000000ffe7000 virtual, 0xffe7000 absolute



Then computer freezes, fans start blowing until I switch it off.

I haven't tried booting with kernel 3.6.9 because I do not known how to test it. Is there a way to replace the kernel on the DVD with 3.6.9? If so, appreciate a quick how-to, and I will try.
Comment 4 Josh Boyer 2013-01-08 11:10:49 EST
Can you remove the 'rhgb' and 'quiet' parameters and possibly install kernel-debug to see if there is more information available on the screen?
Comment 5 Ronald Maas 2013-01-08 21:36:55 EST
I am booting the G5 from the F18 beta PPC64 DVD. The yaboot.conf on the DVD does not contain 'rhgb' and 'quiet' parameters. Pls. let me know if I need to anything else (e.g. edit some other config file in the ISO and burn another DVD).

I booted from DVD using the kernel flags 'debug loglevel=7' but the information displayed is exactly the same as without any kernel flags (see previous post).
Comment 6 Ronald Maas 2013-01-27 22:49:26 EST
When I boot the G5 with the F18 (final) DVD, the following is displayed on screen:

[    0.000000] DART table allocated at: c00000007f000000
[    0.000000] Using PowerMac machine description
[    0.000000] Found initrd at 0xc00000000188000:0xc000000031e02e8
[    0.000000] Found U4 memory controller & host bridge @ 0xF8000000 revision 0x42
[    0.000000] Mapped at 0xd000080080000000
[    0.000000] Found a Shasta mac-io controller, rev: 0, mapped at 0xd000080080050000
[    0.000000] PowerMac motherboard: PowerMac G5 Dual Core
[    0.000000] DART IOMMU initialized for U4 type chipset
[    0.000000] bootconsole [udbg0] enabled
[    0.000000] CPU maps initialized for 1 thread per core
[    0.000000] Starting Linux PPC64 #1 SMP Wed Dec 12 16:07:38 MST 2012
[    0.000000] -----------------------------------------------------
[    0.000000] ppc64_pft_size                = 0x0
[    0.000000] physicalMemorySize            = 0x120000000
[    0.000000] htab_address                  = 0xc000000198000000
[    0.000000] htab_hash_mask                = 0xfffff
[    0.000000] -----------------------------------------------------
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.6.10-4.fc18.ppc64 (mockbuild@) (gcc version 4.7.2 20121109 (Red Hat 4.7.2-8) (GCC) ) #1 SMP Wed Dec 12 16:07:38 MST 2012
CF000012

Setup Arch
[    0.000000] [boot]0012 Setup Arch
[    0.000000] Segment table for CPU 1 at 0xc00000000ffe7000 virtual, 0xffe7000 absolute

Then everything freezes and need to press power button to restart the system.
Comment 7 Josh Boyer 2013-04-01 12:08:19 EDT
I believe there is a fix pending for this issue in the 3.9 kernel.  I'm going to close this out as NEXTRELEASE.  If you still cannot boot with a 3.9-rc5 kernel, please reopen and move this to the F19 release.