Bug 821834

Summary: SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /lib/modules/3.3.4-3.fc16.x86_64/kernel/drivers/i2c.
Product: [Fedora] Fedora Reporter: al morris <allinux4>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:1583d05bbeab4953d0bf006063fdb79a34e9d6c499fcc17f6b64936766482346
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-15 16:01:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description al morris 2012-05-15 10:48:16 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /lib/modules/3.3.4-3.fc16.x86_64/kernel/drivers/i2c.
time:           Tue 15 May 2012 09:48:07 AM CDT

description:
:SELinux is preventing /usr/bin/ruby from 'read' accesses on the directory /lib/modules/3.3.4-3.fc16.x86_64/kernel/drivers/i2c.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ruby should be allowed read access on the i2c directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:object_r:modules_object_t:s0
:Target Objects                /lib/modules/3.3.4-3.fc16.x86_64/kernel/drivers/i2
:                              c [ dir ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.358-1.fc16.x86_64
:Target RPM Packages           kernel-3.3.4-3.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.5-2.fc16.x86_64 #1 SMP Tue May 8
:                              11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Tue 15 May 2012 04:33:26 PM CDT
:Last Seen                     Tue 15 May 2012 04:33:26 PM CDT
:Local ID                      d10b2eac-a1a5-4e29-88d7-1a09856575e3
:
:Raw Audit Messages
:type=AVC msg=audit(1337117606.410:95): avc:  denied  { read } for  pid=1159 comm="deltacloudd" name="i2c" dev="sda3" ino=395403 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1337117606.410:95): avc:  denied  { open } for  pid=1159 comm="deltacloudd" name="i2c" dev="sda3" ino=395403 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1337117606.410:95): arch=x86_64 syscall=openat success=yes exit=ENOEXEC a0=ffffffffffffff9c a1=1dde890 a2=90800 a3=0 items=0 ppid=1108 pid=1159 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,modules_object_t,dir,read
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t modules_object_t:dir { read open };
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t modules_object_t:dir { read open };
:
Comment 1 Miroslav Grepl 2012-05-15 16:01:25 EDT

*** This bug has been marked as a duplicate of bug 821810 ***