This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 823017

Summary: Review Request: erlang-gtknode - Erlang GTK2 binding
Product: [Fedora] Fedora Reporter: Peter Lemenkov <lemenkov>
Component: Package ReviewAssignee: Michel Alexandre Salim <michel>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: michel, notting, package-review
Target Milestone: ---Flags: michel: fedora‑review+
limburgher: fedora‑cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-17 18:20:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 822997    

Description Peter Lemenkov 2012-05-18 15:21:34 EDT
Spec URL: http://peter.fedorapeople.org/erlang-gtknode.spec
SRPM URL: http://peter.fedorapeople.org/erlang-gtknode-0.32-1.fc18.src.rpm
Description: Erlang GTK binding.

Koji scratchbuild for F-18:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4087493

rpmlint:
sulaco ~/rpmbuild/SPECS: rpmlint ../SRPMS/erlang-gtknode-0.32-1.fc18.src.rpm ../RPMS/ppc/erlang-gtknode-*
erlang-gtknode.src: W: invalid-url Source0: massemanet-gtknode-19ddfd5.tar.gz

^^^ this is a github's issue, not mine.

3 packages and 0 specfiles checked; 0 errors, 1 warnings.
sulaco ~/rpmbuild/SPECS:
Comment 1 Michel Alexandre Salim 2012-06-07 04:13:26 EDT
Taking this review
Comment 2 Michel Alexandre Salim 2012-06-07 06:40:03 EDT
* Seems like the latest Git snapshot, which you're packaging, is a post-release -- version 0.32 is commit e4a4581a82 from 2007, the latest commit is from 2011.

Could you change the release tag? see

http://fedoraproject.org/wiki/Packaging:NamingGuidelines#Snapshot_packages

e.g. 1.%{commit_date}git%{git_tag}%{?dist}

* The download link should say 'tarball' not zipball since you use the tarball as the source (and it's smaller than the zip)

* the patch does not indicate if it's been sent upstream - add a comment with the issue URL if one exist, or comment saying "sent to upstream via email"?



Package Review
==============

Key:
- = N/A
x = Pass
! = Fail
? = Not evaluated



==== Generic ====
[x]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: MUST Package successfully compiles and builds into binary rpms on at
     least one supported primary architecture.
[x]: MUST %build honors applicable compiler flags or justifies otherwise.
[x]: MUST All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: MUST Buildroot is not present
     Note: Unless packager wants to package for EPEL5 this is fine
[x]: MUST Package contains no bundled libraries.
[x]: MUST Changelog in prescribed format.
[x]: MUST Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: Clean would be needed if support for EPEL is required
[x]: MUST Sources contain only permissible code or content.
[x]: MUST Each %files section contains %defattr if rpm < 4.4
     Note: Note: defattr macros not found. They would be needed for EPEL5
[x]: MUST Macros in Summary, %description expandable at SRPM build time.
[x]: MUST Package requires other packages for directories it uses.
[x]: MUST Package uses nothing in %doc for runtime.
[x]: MUST Package is not known to require ExcludeArch.
[x]: MUST Permissions on files are set properly.
[x]: MUST Package does not contain duplicates in %files.
[x]: MUST Spec file lacks Packager, Vendor, PreReq tags.
[!]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf is only needed if supporting EPEL5
[-]: MUST Large documentation files are in a -doc subpackage, if required.
[x]: MUST If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %doc.
[x]: MUST License field in the package spec file matches the actual license.
[x]: MUST Package consistently uses macros (instead of hard-coded directory
     names).
[x]: MUST Package is named according to the Package Naming Guidelines.
[x]: MUST Package does not generate any conflict.
[x]: MUST Package obeys FHS, except libexecdir and /usr/target.
[x]: MUST Package must own all directories that it creates.
[x]: MUST Package does not own files or directories owned by other packages.
[x]: MUST Package installs properly.
[x]: MUST Requires correct, justified where necessary.
[x]: MUST Rpmlint output is silent.
[x]: MUST Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: MUST Spec file is legible and written in American English.
[x]: MUST Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: MUST Package contains a SysV-style init script if in need of one.
[x]: MUST File names are valid UTF-8.
[-]: MUST Useful -debuginfo package or justification otherwise.
[x]: SHOULD Reviewer should test that the package builds in mock.
[-]: SHOULD If the source package does not include license text(s) as a
     separate file from upstream, the packager SHOULD query upstream to
     include it.
[x]: SHOULD Dist tag is present.
[x]: SHOULD No file requires outside of /etc, /bin, /sbin, /usr/bin,
     /usr/sbin.
[x]: SHOULD Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: SHOULD Package functions as described.
[x]: SHOULD Latest version is packaged.
[x]: SHOULD Package does not include license text files separate from
     upstream.
[!]: SHOULD Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[x]: SHOULD SourceX / PatchY prefixed with %{name}.
[x]: SHOULD SourceX is a working URL.
[-]: SHOULD Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: SHOULD Package should compile and build into binary rpms on all supported
     architectures.
[-]: SHOULD %check is present and all tests pass.
     Upstream doesn't provide tests
[-]: SHOULD Packages should try to preserve timestamps of original installed
     files.
     All the installed files are compiled anyway, no point preserving the
     exact build time
[x]: SHOULD Spec use %global instead of %define.

Issues:
[!]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf is only needed if supporting EPEL5
See: None
[!]: SHOULD Patches link to upstream bugs/comments/lists or are otherwise
     justified.
     Has this been upstreamed, and if possible, is there a public URL to the
     bug report?

Generated by fedora-review 0.2.0git
External plugins:
Comment 3 Peter Lemenkov 2012-06-07 15:00:38 EDT
Thanks for reviewing this!

Fixed numbering scheme, patches were sent upstream (and added one more) and added comment on how to get proper tarball:

* http://peter.fedorapeople.org/erlang-gtknode.spec
* http://peter.fedorapeople.org/erlang-gtknode-0.32-2.20110310git19ddfd5.fc18.src.rpm

Koji scratchbuild for F-18:

* http://koji.fedoraproject.org/koji/taskinfo?taskID=4137549
Comment 4 Michel Alexandre Salim 2012-06-09 08:48:26 EDT
Everything looks good - APPROVED
Comment 5 Peter Lemenkov 2012-06-09 08:51:20 EDT
(In reply to comment #4)
> Everything looks good - APPROVED

Thanks for the review!

New Package SCM Request
=======================
Package Name: erlang-gtknode
Short Description: Erlang GTK2 binding
Owners: peter
Branches: f16 f17 el6
InitialCC:
Comment 6 Jon Ciesla 2012-06-09 13:23:37 EDT
Git done (by process-git-requests).
Comment 7 Fedora Update System 2012-06-09 15:01:41 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/erlang-gtknode-0.32-2.20110310git19ddfd5.fc16
Comment 8 Fedora Update System 2012-06-09 15:01:50 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/erlang-gtknode-0.32-2.20110310git19ddfd5.fc17
Comment 9 Fedora Update System 2012-06-09 15:02:21 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/erlang-gtknode-0.32-2.20110310git19ddfd5.el6
Comment 10 Fedora Update System 2012-06-09 21:30:06 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.fc16 has been pushed to the Fedora 16 testing repository.
Comment 11 Fedora Update System 2012-06-17 18:20:56 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.fc16 has been pushed to the Fedora 16 stable repository.
Comment 12 Fedora Update System 2012-06-17 18:25:25 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.fc17 has been pushed to the Fedora 17 stable repository.
Comment 13 Fedora Update System 2012-06-28 12:08:09 EDT
erlang-gtknode-0.32-2.20110310git19ddfd5.el6 has been pushed to the Fedora EPEL 6 stable repository.