Bug 823638

Summary: RFE: RHEL AMI MOTD
Product: Red Hat Enterprise Linux 6 Reporter: Jay Greguske <jgregusk>
Component: setupAssignee: Ondrej Vasik <ovasik>
Status: CLOSED WONTFIX QA Contact: qe-baseos-daemons
Severity: medium Docs Contact:
Priority: medium    
Version: 6.3CC: atodorov, cpelland, jgregusk, syeghiay
Target Milestone: rcKeywords: EC2, FutureFeature
Target Release: 6.5   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 823639 (view as bug list) Environment:
Last Closed: 2013-01-30 15:39:24 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 823639    

Description Jay Greguske 2012-05-21 14:39:27 EDT
Description of problem:
The Message of the Day sucks in RHEL AMIs


Steps to Reproduce:
1. Launch a RHEL AMI
2. Log in and review the non-existent, boring MOTD
  
Actual results:
No MOTD given

Expected results:
https://github.com/deater/linux_logo/blob/master/logos/distributions/redhat-banner.logo

Maybe include a number of updates available or something.
Comment 2 RHEL Product and Program Management 2012-07-10 02:59:24 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:48:07 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Joe Vlcek 2013-01-03 11:25:57 EST
Is this still an issue?

Is this cloud-init related? If so, since the bug was initially filed,
a much newer version of cloud-init is now targeted for RHEL6.4.
Please confirm this is still an issue and if it is cloud-init
related.

If it is still an issue is it still a feature that is needed in
6.4 and if so, what are the requirements?
Comment 7 Jay Greguske 2013-01-07 09:16:29 EST
It's still needed but I don't know if I'd call the MotD a blocker.
Comment 8 Joe Vlcek 2013-01-07 09:30:20 EST
If an AMI does not contain the cloud-init package is the MOTD correctly
displayed?

What version of cloud-init is being used?

Please direct me to the AMI that depicts this issue.
Comment 9 Joe Vlcek 2013-01-07 09:38:11 EST
Why is this an issue for the AMI, when it seems to act the same
as the bare metal, el6, installation I have where there also is
no MOTD?
Comment 10 Jay Greguske 2013-01-07 10:10:50 EST
The RFE was just to have an MotD, instrumented by cloud-init. It's not a blocker, I'll propose the next release.
Comment 11 Joe Vlcek 2013-01-07 10:49:20 EST
/etc/motd is provided in package "setup". I think using package "cloud-init" to add content to it would be a kludge. Why not just update the "setup" package to add the content?

Any reason why the component shouldn't be changed to:  "setup" ?
Comment 12 Joe Vlcek 2013-01-14 15:36:50 EST
Moving to Component: "setup" since it provides /etc/motd.

If /etc/motd is to have the suggested banner content it should
likely be delivered that way and not altered by cloud-init at
boot time. Since not all images will use cloud-init and ...
Comment 14 Ondrej Vasik 2013-01-15 11:05:06 EST
Traditionally, motd is intentionally empty in the setup package - as it should be used for administrators for MOTD. I don't think we should provide any default there. There are other files in setup, which are modified by other packages/users - and it is expected this may happen - like /etc/exports, /etc/passwd , /etc/shadow ...therefore they don't have checks for md5 mtime and size in rpm -V. For me it is wontfix for setup package - but if you want to modify it in cloud-init package, feel free to do so (please take it back, otherwise I'll just close it)...
Comment 15 Ondrej Vasik 2013-01-30 15:39:24 EST
CLosing...