Bug 824204

Summary: please drop After= lines for various target units in libvirtd systemd unit
Product: [Fedora] Fedora Reporter: Lennart Poettering <lpoetter>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: berrange, clalancette, dougsland, itamar, jforbes, jyang, laine, libvirt-maint, mclasen, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-30 18:05:13 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Lennart Poettering 2012-05-22 21:21:18 EDT
The libvirtd unit file currently includes these four lines:

After=syslog.target
After=udev.target
After=avahi.target
After=dbus.target

Please drop all four of them. The first one is obsolete and unnecessary, the second and third one don't even exist, and are unnecessary too. The third one is obsolete and unnecessary too.

This is not important as "dangling" units do not influence the dep tree too much, but they do litter the output of several commands and confuse the user.
Comment 1 Daniel Berrange 2012-05-23 06:59:27 EDT
One of these is already fixed upstream

commit 6cfc3f8f4facc7f549ee494b216bde18d15a1d33
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue May 15 17:33:00 2012 +0100

    Remove bogus udev.target dep from libvirtd unit


I will remove the others shortly too.
Comment 3 Daniel Berrange 2012-05-23 11:17:44 EDT
Fixed the remaining issues now

commit 4c7973e184a4ce52f78e63f1a92f9597709279ab
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Wed May 23 12:01:57 2012 +0100

    Remove more bogus systemd service dependencies
    
    Adding syslog.target is obsolete, avahi.target does not
    exist and dbus.target is also obsolete
    
    Reported-by: Lennart Poettering <lpoetter@redhat.com>
    Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
Comment 4 Daniel Berrange 2012-06-13 09:11:22 EDT
*** Bug 831622 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-06-19 11:46:29 EDT
libvirt-0.9.11.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-2.fc17
Comment 6 Fedora Update System 2012-06-20 15:24:07 EDT
Package libvirt-0.9.11.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.9.11.4-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9708/libvirt-0.9.11.4-2.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-28 10:05:55 EDT
libvirt-0.9.11.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-3.fc17
Comment 8 Fedora Update System 2012-06-30 18:05:13 EDT
libvirt-0.9.11.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.