Bug 82426

Summary: aspell 0.33 hangs on large xml documents
Product: [Retired] Red Hat Linux Reporter: Judd Rogers <juddrogers>
Component: aspellAssignee: Eido Inoue <havill>
Status: CLOSED DEFERRED QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-19 21:37:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Judd Rogers 2003-01-22 01:06:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Redhat 8.0 ships with
aspell --version
@(#) International Ispell Version 3.1.20 (but really Aspell .33.7.1 alpha)
rpm -q aspell
aspell-0.33.7.1-16

If I run this version against large xml documents (DocBook DTD), aspell consumes
all memory and cpu but never displays any spelling errors.

So I downloaded the newest version, built it and installed it. Problem solved.

Time for y'all to step up. :-)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
spell check a big xml file.    

Actual Results:  most of memory consumed 
all of cpu consumed

Expected Results:  spell checking dialog should appear on console

Additional info:

Sorry, Can't send you the xml. Confidential.

Comment 1 Eido Inoue 2003-02-19 21:37:01 UTC
aspell will be upgraded with the next release