Bug 82429

Summary: Unhandled exception during installation of Red Hat 8.0
Product: [Retired] Red Hat Linux Reporter: William Johnsen <wajohnsen>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Traceback file of unhandled exception none

Description William Johnsen 2003-01-22 01:25:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
During installation, after entering the root password and moving onto the next
task, a little window pops up about loading (or reading) packages. Soon
thereafter, another larger window pops up with an unhandled exception. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Regardless of the steps I take or the installation type (text or graphical,
personal or server)

Actual Results:  Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 120, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/installmethod.py", line 60, in readComps
    return self.readCompsViaMethod(hdlist)
  File "/usr/lib/anaconda/image.py", line 33, in readCompsViaMethod
    return ComponentSet(fname, hdlist)
  File "/usr/lib/anaconda/comps.py", line 1013, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 712, in readCompsFile
    self.compsxml = rhpl.comps.Comps(file)
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 297, in __init__
    self.load (filename)
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 304, in load
    doc = libxml2.parseMemory(file, len(file))
  File "/usr/lib/python2.2/site-packages/libxml2.py", line 717, in parseMemory
    if ret == None:raise parserError('xmlParseMemory() failed')
parserError: xmlParseMemory() failed

Additional info:

I saved traceback if needed. Only the top of the traceback file was entered here
since the bug report form fails to accept 0.6 MB or text.

Comment 1 William Johnsen 2003-01-22 01:28:15 UTC
Created attachment 89498 [details]
Traceback file of unhandled exception

Comment 2 Jeremy Katz 2003-01-22 05:55:09 UTC
Could you please verify your media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?

Comment 3 William Johnsen 2003-01-22 14:22:16 UTC
Media was verified on installation machine before initial installation. After
exception occurred, media was verified 2 more times. All 3 CDs were verified.

Comment 4 William Johnsen 2003-01-22 14:24:30 UTC
Also, used the iso file checker (md5) to ensure proper key.

Comment 5 William Johnsen 2003-01-24 20:52:27 UTC
Installed RedHat v7.3 last night without issue. Tried to install v8.0 over v7.3
with the upgrade option instead of the full installtion. When the "reading
packages" window popped up, same error occurred.

Comment 6 William Johnsen 2003-01-27 06:43:35 UTC
Thought it might be helpful for you to know that I created, verified, and
installed v7.3 media in precisely the same manner that I did with v8.0 - using
iso images, verifying the media key with md5, booted and installed from cd-rom.
v8.0 had an extra step to verify the media after boot just prior to
installation.  All defaults selected, then location, time zone, and packages
altered post install success.

Comment 7 Michael Fulbright 2003-01-30 20:45:39 UTC
This error is the result of a read error from the media, causing the parser to fail.

If you purchased this install media from Red Hat you can get replacement media.

*** This bug has been marked as a duplicate of 75008 ***

Comment 8 William Johnsen 2003-02-03 06:47:23 UTC
Successful attempt to install this media on different computer. No Unhandled
Exception occurred where indicated.

Comment 9 Michael Fulbright 2003-02-03 19:16:45 UTC

*** This bug has been marked as a duplicate of 75008 ***

Comment 10 Red Hat Bugzilla 2006-02-21 18:51:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.