Bug 826272

Summary: wrong stage2 download url for installer
Product: [Fedora] Fedora Reporter: Grégoire Paris <postmaster>
Component: preupgradeAssignee: dracut-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 17CC: awilliam, dracut-maint, htl10, hughsient, jonathan, lornden
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-31 14:42:21 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Grégoire Paris 2012-05-29 17:45:00 EDT
Description of problem:
I tried to upgrade to F17 using preupgrade. I have little space on /boot, so preupgrade said I couldn't download the installer, and that it would be downloaded during the installation process. Fine.
During the installation process, I have messages about curl getting a 404 for 
http://fr2.rpmfind.net/linux/fedora/linux/releases/17/Fedora/x86_64/os/LiveOS/squashfs.img/LiveOS/squashfs.img
Obiously, the url is bogus

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. shrink your /boot partition so that preupgrade cannot download the installer
2. try to install
  
Actual results:
attempt to download installer from http://fr2.rpmfind.net/linux/fedora/linux/releases/17/Fedora/x86_64/os/LiveOS/squashfs.img/LiveOS/squashfs.img , something like that...

Expected results:
attempt to http://fr2.rpmfind.net/linux/fedora/linux/releases/17/Fedora/x86_64/os/LiveOS/squashfs.img

Additional info:
Comment 1 Hin-Tak Leung 2012-05-30 07:05:28 EDT
Just a me-too. Saw the same thing. Had to run the grubby command manually with stage2=http://.../os/ without the last bit; it looks like dracut appends LiveOS/squashfs.img to the stage2 parameter to cause that error.
Comment 2 Hin-Tak Leung 2012-05-30 07:18:32 EDT
Can the original poster change the subject to be more specific, about the stage2 url being wrong?
Comment 3 Grégoire Paris 2012-05-30 08:28:33 EDT
Done (In reply to comment #2)
> Can the original poster change the subject to be more specific, about the
> stage2 url being wrong?
Comment 4 Hin-Tak Leung 2012-05-30 13:52:23 EDT
More details: the solution I came up with, was to watch preupgrade's associated console messages, it says:

/sbin/grubby --title="Upgrade to Fedora 17 (Beefy Miracle)" --remove-kernel="/boot/upgrade/vmlinuz" --add-kernel="/boot/upgrade/vmlinuz" --initrd="/boot/upgrade/initrd.img" --args="preupgrade repo=hd::/var/cache/yum/preupgrade  ks=hd:UUID=<myhdid>:/upgrade/ks.cfg stage2=http://mirror.bytemark.co.uk/fedora/linux/releases/17/Fedora/x86_64/os/LiveOS/squashfs.img"

Just cut and paste and remove the last part of that after finishing running preupgrade, and execute it as root, before rebooting:

/sbin/grubby --title="Upgrade to Fedora 17 (Beefy Miracle)" --remove-kernel="/boot/upgrade/vmlinuz" --add-kernel="/boot/upgrade/vmlinuz" --initrd="/boot/upgrade/initrd.img" --args="preupgrade repo=hd::/var/cache/yum/preupgrade  ks=hd:UUID=<myhdid>:/upgrade/ks.cfg stage2=http://mirror.bytemark.co.uk/fedora/linux/releases/17/Fedora/x86_64/os/"
Comment 5 Hin-Tak Leung 2012-05-30 13:55:22 EDT
Your UUID will differ from mine, as well as the choice of fedora mirror. This got me actually starting to upgrade. (hit a few other problems later, but I am *mostly* on f17 now..).
Comment 6 Grégoire Paris 2012-05-30 17:06:09 EDT
Clever. I also started preupgrade from the console but did not notice that the path apperaed here. I'm tried your solution, I'm going to reboot right now with the newly generated configuration.
(In reply to comment #4)
> More details: the solution I came up with, was to watch preupgrade's
> associated console messages, it says:
> 
> /sbin/grubby --title="Upgrade to Fedora 17 (Beefy Miracle)"
> --remove-kernel="/boot/upgrade/vmlinuz" --add-kernel="/boot/upgrade/vmlinuz"
> --initrd="/boot/upgrade/initrd.img" --args="preupgrade
> repo=hd::/var/cache/yum/preupgrade  ks=hd:UUID=<myhdid>:/upgrade/ks.cfg
> stage2=http://mirror.bytemark.co.uk/fedora/linux/releases/17/Fedora/x86_64/
> os/LiveOS/squashfs.img"
> 
> Just cut and paste and remove the last part of that after finishing running
> preupgrade, and execute it as root, before rebooting:
> 
> /sbin/grubby --title="Upgrade to Fedora 17 (Beefy Miracle)"
> --remove-kernel="/boot/upgrade/vmlinuz" --add-kernel="/boot/upgrade/vmlinuz"
> --initrd="/boot/upgrade/initrd.img" --args="preupgrade
> repo=hd::/var/cache/yum/preupgrade  ks=hd:UUID=<myhdid>:/upgrade/ks.cfg
> stage2=http://mirror.bytemark.co.uk/fedora/linux/releases/17/Fedora/x86_64/
> os/"
Comment 7 Hin-Tak Leung 2012-05-30 17:41:50 EDT
(In reply to comment #6)
> Clever. I also started preupgrade from the console but did not notice that
> the path apperaed here. I'm tried your solution, I'm going to reboot right
> now with the newly generated configuration.

Good luck - I have hit 4 bugs in total - well, actually 5, counting 
http://fedoraproject.org/wiki/Common_F17_bugs#preupgrade_from_Fedora_16_does_not_update_bootloader_configuration

but I am mostly f17 now...

The other 3 are:
[Bug 822008] Silent lockup in upgrade of sbcl
[Bug 826668] gridengine uninstall script(s) failed, causing preupgrade to abort...
[Bug 826497] kde-filesystem failed to install due to directory/symlink difference...
Comment 8 Grégoire Paris 2012-05-30 18:57:35 EDT
Wow. Looks like I'm not so unlucky after all... thanks again, it worked like a charm!
(In reply to comment #7)
> (In reply to comment #6)
> > Clever. I also started preupgrade from the console but did not notice that
> > the path apperaed here. I'm tried your solution, I'm going to reboot right
> > now with the newly generated configuration.
> 
> Good luck - I have hit 4 bugs in total - well, actually 5, counting 
> http://fedoraproject.org/wiki/
> Common_F17_bugs#preupgrade_from_Fedora_16_does_not_update_bootloader_configur
> ation
> 
> but I am mostly f17 now...
> 
> The other 3 are:
> [Bug 822008] Silent lockup in upgrade of sbcl
> [Bug 826668] gridengine uninstall script(s) failed, causing preupgrade to
> abort...
> [Bug 826497] kde-filesystem failed to install due to directory/symlink
> difference...
Comment 9 Adam Williamson 2012-05-31 14:42:21 EDT

*** This bug has been marked as a duplicate of bug 813973 ***