Bug 826705

Summary: uvcvideo driver is missing "Focus" control (and others?) for Logitech, Inc. Webcam Pro 9000
Product: [Fedora] Fedora Reporter: David Mansfield <bugzilla>
Component: libwebcamAssignee: Michael Cronenworth <mike>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: gansalmon, hdegoede, itamar, jonathan, kernel-maint, madhu.chinakonda, mike
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libwebcam-0.2.2-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-02 04:53:13 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David Mansfield 2012-05-30 15:55:59 EDT
Description of problem:

In Fedora 16 a bunch of "controls" for my webcam were available via the uvcdynctrl command line program, and also guvcview gui.  In particular "Focus", which is really necessary is now gone.  The xml describing my camera is: 

/usr/share/uvcdynctrl/data/046d/logitech.xml

but this cannot be loaded with uvcdynctrl -i /usr/share/uvcdynctrl/data/046d/logitech.xml

due to the error:

 /usr/share/uvcdynctrl/data/046d/logitech.xml: error: device 'video0' skipped because the driver 'uvcvideo' behind it does not seem to support dynamic controls.

Version-Release number of selected component (if applicable):
kernel 3.3.7-1.fc17.x86_64
libwebcam-0.2.0-5.20100322svn.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.run uvcdynctrl -c and look at list of controls.
2.
3.
  
Actual results:
  Tilt (Absolute)
  Pan (Absolute)
  Exposure, Auto Priority
  Exposure (Absolute)
  Backlight Compensation
  Sharpness
  White Balance Temperature
  Power Line Frequency
  Gain
  White Balance Temperature, Auto
  Saturation
  Contrast
  Brightness


Expected results (this also has some attribute values, this is output of a script I had last run in F16):

#Raw bits per pixel: 0
#Disable video processing: 0
#LED1 Frequency: 0
#LED1 Mode: 3
#Focus: 231
#Exposure, Auto Priority: 0
#Exposure (Absolute): 310
#Exposure, Auto: 3
#Backlight Compensation: 1
#Sharpness: 191
#White Balance Temperature: 9760
#Power Line Frequency: 2
#Gain: 255
#White Balance Temperature, Auto: 1
#Saturation: 0
#Contrast: 140
#Brightness: 210



Additional info:
Note: "Tilt" and "Pan" are new.
Comment 1 Michael Cronenworth 2012-05-30 16:00:14 EDT
Already fixed.

https://admin.fedoraproject.org/updates/FEDORA-2012-8342/libwebcam-0.2.2-1.fc16

# yum update --enablerepo=updates-testing libwebcam
Comment 2 David Mansfield 2012-05-30 16:04:59 EDT
I installed the above update.  I can now load the XML.

I don't get the "Focus" control with this update alone.  It seems to be actually a kernel bug.

See:

https://bugzilla.kernel.org/show_bug.cgi?id=42684

I DO get a bunch of the above "missing" controls back, however, but not "Focus" which is very important.

Can you please reopen?  I changed the subject to be more specific.
Comment 3 Michael Cronenworth 2012-05-30 16:08:07 EDT
Reassigning to kernel.
Comment 4 David Mansfield 2012-05-30 21:41:04 EDT
ok.  Michael was almost right in comment#1, this bug was fixed.  However, the the package(s) which needed to be updated were uvcdynctrl and uvcdynctrl-data, which are part of the libwebcam project, but not updated with the command given.

After doing some debugging (another hour of my life) I discovered what the maintainers already knew, which was that the XML file was missing the product_id for my webcam (added in latest version), AND that the old version of the program ignored the product_id altogether (although not working with latest kernels), hence it going from working to not working.

With the new code, it seems to be working again.

Please push to stable! Close this bug!
Comment 5 Hans de Goede 2012-06-02 04:53:13 EDT
The update fixing this has been pushed to stable last Thursday, closing.