Bug 827513

Summary: Unable to boot from Install DVD, NetInstall DVD or any other boot images
Product: [Fedora] Fedora Reporter: John William <jw2357>
Component: dracutAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 17CC: anaconda-maint-list, dennis, dracut-maint, g.kaviyarasu, harald, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-05 05:20:18 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description John William 2012-06-01 12:26:50 EDT
Description of problem:
Create any boot medium - I tried Install DVD, Net Install DVD and USB install.


Version-Release number of selected component (if applicable):
Fedora 17 final

How reproducible:
Every time

Steps to Reproduce:
1. Create boot media.
2. Attempt to boot.
3. Boot fail.
  
Actual results:
The system fails to boot. It ends with:

dracut Warning: Unable to process initqueue
dracut Warning: /dev/disk/by-label/Fedorax2017x20x86_64 does not exist
dracut Warning: /dev/mapper/live-rw does not exist

(As an example - from booting the Install DVD)

Expected results:
Normal boot -> install F17

Additional info:
Machine is Athlon 64, Asus A8N5X MB with Plextor DVD-RW PIDE drive and two PIDE HDs. Machine is currently running F16. Downloaded image checksums were good, so I do not suspect file corruption. Since I cannot boot any F17 medium, I have not verified checksums on the media, but I used different physical media for each of the boot attempts.

I also tried extracting the isolinux directory from the ISO image and booting it manually, no-go there either.
Comment 1 John William 2012-06-03 13:27:16 EDT
Problem seems more related to dracut than anaconda.
Comment 2 Harald Hoyer 2012-06-04 05:53:40 EDT
workaround:

edit the kernel command line of the DVD and specify:

root=LIVE:/dev/sr0 instead of the old root=LIVE:.... argument
Comment 3 John William 2012-06-04 17:00:14 EDT
Harold: I just tried your suggestion and was able to boot into the installer from the full install DVD. Thank you for taking the time to provide this information!

I do not have time today to grind through the full installation, but will do so and update this bug or file a new one if I encounter any additional problems.

Thank you for taking the time to help!
Comment 4 Harald Hoyer 2012-06-05 05:20:18 EDT

*** This bug has been marked as a duplicate of bug 824617 ***