Bug 828867

Summary: [te] failed pofilter varialbes tests for subscription-manager translations
Product: Red Hat Enterprise Linux 5 Reporter: Sharath Dwaral <fsharath>
Component: subscription-managerAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: Entitlement Bugs <entitlement-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.9CC: ankit, jgalipea, jmolet, kkrothap
Target Milestone: betaKeywords: i18n, Translation
Target Release: 5.9   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-07 22:53:48 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 771748    

Description Sharath Dwaral 2012-06-05 09:42:19 EDT
Description of problem:
The gnome variables were not properly translated for 'te' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo -o /usr/share/locale/te/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t variables /usr/share/locale/te/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-12 01:53-0400\n"
"Last-Translator: kkrothap <kkrothap@fedoraproject.org>\n"
"Language-Team: American English <kde-i18n-doc@kde.org>\n"
"Language: te\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1);\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) variables: Added variables: %s
msgid ""
"\n"
"This machine appears to be already registered to Certificate-based RHN.  Exiting."
msgstr ""
"\n"
"ఈ మైగ్రేషన్ స్క్రిప్టునకు సిస్టమ్ RHN హోస్టెస్ క్లాసిక్‌కు నమోదగుట అవసరం.\n"
"ఏమైనప్పటికీ యీ సిస్టమ్  '%s' కు నమోదైనట్లు కనిపిస్తోంది.\n"
"నిష్క్రమిస్తోంది."


Actual results:
Shown above

Expected results:

>This Bug has been reported earlier in pofileter newlines failes case. 
>First the new lines are to fixed and second we can see that an extra >descriptor '%s' in the translation which has to be removed



Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#variables
Comment 2 Sharath Dwaral 2012-06-05 09:51:24 EDT
>This Bug has been reported earlier in pofileter newlines failure case. 
>First the new lines are to fixed and second we can see that an extra descriptor '%s' in the translation which has to be removed
Comment 4 Bryan Kearney 2012-06-22 10:23:34 EDT
Edited the file to remove the extra %s.
Comment 5 Krishna Babu K 2012-06-25 08:06:50 EDT
Hi,

Translation replaced with this 
"ఈ వ్యవస్థ యిప్పటికే ధృవీకరణపత్ర-ఆధారిత RHN కు నమోదైనట్లు కనిపిస్తోంది. నిష్క్రమిస్తోంది." %s removed as it is not in msgid.

thanks,
Krishna.
Comment 6 Bryan Kearney 2012-06-25 15:24:56 EDT
fixed in maseter at 061267bcf9bee531d2b2f9d3633345d8915b4911
Comment 7 RHEL Product and Program Management 2012-06-26 14:09:07 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 9 Sharath Dwaral 2012-07-12 15:06:27 EDT
Version:

rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Verification :

# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo -o /usr/share/locale/te/LC_MESSAGES/rhsm.po
# pofilter --gnome -t variables /usr/share/locale/te/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

Moving bug to VERIFIED
Comment 11 errata-xmlrpc 2013-01-07 22:53:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html