Bug 828969

Summary: [te] failed pofilter options test for subscription-manager translations
Product: Red Hat Enterprise Linux 5 Reporter: Sharath Dwaral <fsharath>
Component: subscription-managerAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: Entitlement Bugs <entitlement-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.9CC: ankit, awood, jgalipea, kkrothap
Target Milestone: betaKeywords: i18n, Translation
Target Release: 5.9   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-07 22:54:05 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 771748    

Description Sharath Dwaral 2012-06-05 12:14:53 EDT
Description of problem:
The gnome options were not properly translated for 'te' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo -o /usr/share/locale/te/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t options /usr/share/locale/te/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-12 01:53-0400\n"
"Last-Translator: kkrothap <kkrothap@fedoraproject.org>\n"
"Language-Team: American English <kde-i18n-doc@kde.org>\n"
"Language: te\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1);\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) options: Missing or translated option '--all'
msgid "One of --serial or --all must be provided"
msgstr "--serial లేదా -all యేదో వొకటి యివ్వాలి"


Steps to Reproduce:

Actual results:
Shown above

Expected results:

msgid "One of --serial or --all must be provided"
>msgstr "--serial లేదా --all యేదో వొకటి యివ్వాలి"


Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#options
Comment 3 Alex Wood 2012-06-18 12:58:05 EDT
commit 53aa24dd6e231146f965908bf214e938eab133e4
Refs: subscription-manager-1.0.2-1-88-g53aa24d
Author:     Bryan Kearney <bkearney@redhat.com>
AuthorDate: Tue Jun 5 16:58:08 2012 -0400
Commit:     Bryan Kearney <bkearney@redhat.com>
CommitDate: Wed Jun 6 15:38:39 2012 -0400

    828969: Fix the options in the translated string
Comment 4 RHEL Product and Program Management 2012-06-18 13:08:10 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Krishna Babu K 2012-06-25 08:04:04 EDT
Hi,

Translation crrected to

msgstr "--serial లేదా --all యేదో వొకటి యివ్వాలి"

thanks,
krishna.
Comment 7 Sharath Dwaral 2012-07-12 16:08:46 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Verification:

# msgunfmt --no-wrap /usr/share/locale/te/LC_MESSAGES/rhsm.mo -o /usr/share/locale/te/LC_MESSAGES/rhsm.po

# pofilter --gnome -t options /usr/share/locale/te/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

Moving bug to VERIFIED
Comment 9 errata-xmlrpc 2013-01-07 22:54:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html