Bug 829486

Summary: [fr] failed pofilter unchanged options test for subscription manager translations
Product: Red Hat Enterprise Linux 5 Reporter: Sharath Dwaral <fsharath>
Component: subscription-managerAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: Entitlement Bugs <entitlement-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.9CC: ankit, awood, jgalipea, jmolet, sfriedma
Target Milestone: betaKeywords: i18n, Translation
Target Release: 5.9   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-07 22:54:28 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 771748    

Description Sharath Dwaral 2012-06-06 17:19:16 EDT
Description of problem:
Some of gnome English words remanin ubtranslated for 'fr' language.  Sample output is shown below, 

Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/fr/LC_MESSAGES/rhsm.mo -o /usr/share/locale/fr/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t unchanged /usr/share/locale/fr/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: fr\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-11 09:20-0400\n"
"Last-Translator: samfreemanz <sfriedma@redhat.com>\n"
"Language-Team: French <fr@li.org>\n"
"Language: fr\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n > 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) unchanged: Consider translating
msgid "%prog [options]"
msgstr "%prog [options]"

# (pofilter) unchanged: Consider translating
msgid "Arch"
msgstr "Arch"

# (pofilter) unchanged: Consider translating
msgid "Options"
msgstr "Options"

# (pofilter) unchanged: Consider translating
msgid "Type"
msgstr "Type"

# (pofilter) unchanged: Consider translating
msgid "Version"
msgstr "Version"

# (pofilter) unchanged: Consider translating
msgid "page 1"
msgstr "page 1"

# (pofilter) unchanged: Consider translating
msgid "page 2"
msgstr "page 2"

# (pofilter) unchanged: Consider translating
msgid "page 3"
msgstr "page 3"

# (pofilter) unchanged: Consider translating
msgid "page 4"
msgstr "page 4"

Actual results:
Shown above

Expected results:

> english words not translated to it's respective native language.

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#unchanged
Comment 2 Bryan Kearney 2012-06-25 16:36:48 EDT
Removed untranslated words to force a re-translation
Comment 3 Bryan Kearney 2012-06-26 20:25:23 EDT
fixed in master in a13d529ce67b99c2f42da6b91985a8fae31f161c
Comment 4 Sam Friedmann 2012-06-26 22:06:17 EDT
Hello,

With the exception of "Arch" (which has now been translated) all of these words are the same in French and English.


Thanks,


Sam
Comment 5 RHEL Product and Program Management 2012-06-28 11:19:09 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 Sharath Dwaral 2012-07-16 16:35:10 EDT
version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.0.9-1.git.22.35b5155.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.22.35b5155.el5
subscription-manager-gui-1.0.9-1.git.22.35b5155.el5
subscription-manager-firstboot-1.0.9-1.git.22.35b5155.el5

Verfication:
# msgunfmt --no-wrap /usr/share/locale/fr/LC_MESSAGES/rhsm.mo -o /usr/share/locale/fr/LC_MESSAGES/rhsm.po
[root@fsharath-rhel59server sub-man]# pofilter --gnome -t unchanged /usr/share/locale/fr/LC_MESSAGES/rhsm.po

....... Resulting output are all Ignore cases........

Moving bug to VERIFIED
Comment 9 errata-xmlrpc 2013-01-07 22:54:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html