Bug 829887

Summary: 'rhc domain status' asks for PEM password even though ssh-agent is running
Product: OKD Reporter: Adam Miller <admiller>
Component: Command Line InterfaceAssignee: Fotios Lindiakos <fotios>
Status: CLOSED CURRENTRELEASE QA Contact: libra bugs <libra-bugs>
Severity: low Docs Contact:
Priority: medium    
Version: 2.xCC: bmeng, ccoleman, jkeck, qgong, rmillner, xtian
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-13 19:43:26 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Adam Miller 2012-06-07 14:35:54 EDT
Description of problem:
'rhc domain status' asked for PEM password even though it should use ssh-agent

Version-Release number of selected component (if applicable):
gem version: rhc (0.94.1)
ruby version: ruby-1.8.7.358-1.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:

$ rhc domain status
Password: ************

Analyzing system
..Enter PEM pass phrase:
.....
=========================================================
||  Congratulations, your system has passed all tests  ||
=========================================================

$ rhc domain show
Password: ************


User Info
=========
Namespace: admiller
  RHLogin: admiller@redhat.com


Application Info
================
No applications found.  You can use 'rhc app create' to create new applications.
  
Actual results:
'rhc domain status' asks for PEM password but should not.


Expected results:
'rhc domain status' should not ask for PEM password just as 'rhc domain show' does not.


Additional info:
Commands and output above.
Comment 1 Clayton Coleman 2012-06-15 13:33:05 EDT
RHC domain status is less important now that we have other things.  Going to drop severity to low to reflect that we can exit the sprint with this defect.
Comment 2 Fotios Lindiakos 2012-06-15 18:54:02 EDT
This is fixed in https://github.com/openshift/os-client-tools/pull/63. We can merge it if somebody does a double check for me.
Comment 3 Xiaoli Tian 2012-06-28 23:22:21 EDT
Move it ON_QA, since the fix is merged.
Comment 4 Meng Bo 2012-06-29 02:17:05 EDT
Checked on latest rhc client 0.95.5, rhc domain status will not ask for the passphrase after adding the private key to running ssh-agent anymore.