Bug 830843

Summary: Computer freezes when trying to edit boot entry on grub2
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: grub2Assignee: Peter Jones <pjones>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: bcl, bobningx, dennis, mads, pjones, stephent98
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-01 04:55:36 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
The grub.cfg file I tried to edit the 1st kernel entry in none

Description Tom Horsley 2012-06-11 10:01:59 EDT
Description of problem:

I added boot_delay=100 to my kernel args to try and capture a kernel walkback
message. When rebooting the system I typed 'e' in the grub2 menu to edit the
kernel command line to remove this so rebooting would work faster. I moved the
cursor (painfully slowly) out to the start of the boot_delay I had put on the
end of a very long line. I typed "del" about 3 or 4 times to delete the
characters at the end, and after those 3 or 4 times, my system apparently
froze up. I couldn't delete any more characters, I couldn't hit ESC to get
back to grub menu, nothing worked. Even Ctrl-Alt-Del didn't work. I had to
power cycle the machine to get back.

It is a very long line. I don't know if the line wrapping messed it up.


Version-Release number of selected component (if applicable):
grub2-2.0-0.25.beta4.fc17.x86_64


How reproducible:
Only tried it once so far.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
frozen system

Expected results:
ability to edit kernel command line.

Additional info:
Comment 1 Mads Kiilerich 2012-06-11 10:04:08 EDT
This should be fixed in http://koji.fedoraproject.org/koji/buildinfo?buildID=322368 - please confirm.
Comment 2 Tom Horsley 2012-06-11 10:05:43 EDT
Created attachment 590944 [details]
The grub.cfg file I tried to edit the 1st kernel entry in

Here's the grub.cfg file I was trying to edit.

The line is very long. It wrapped even on the 1920x1200 monitor I have.
Comment 3 Tom Horsley 2012-06-11 11:47:16 EDT
OK, I got the beta6 installed (after discovering that the rpm apparently
doesn't do the grub2-install for me :-), and I didn't freeze my system, but
the editing still didn't work:

In this case I moved the cursor down to the line ending in boot_delay=100.

I then type Ctrl-E to get to the end.

I then hit the backspace key 14 times to erase the boot_delay=100 string,
but the screen still said "boot_del", so it stopped erasing characters
on the display about half way through.

I then when ahead and rebooted with that edited kernel entry, and
the /var/log/messages "kernel command line" message does not have
a boot_del on the end, so it apparently erased the whole thing as far as
booting is concerned, but it still has a real problem with the way it
displays the edits on the screen.
Comment 4 Mads Kiilerich 2012-06-11 12:04:57 EDT
Did you have a line wrap after "boot_del" ... or can you attach a photo to explain exactly how it looked like?

Was it possible to move the cursor around and edit elsewhere after the erasing had stopped working?
Comment 5 Tom Horsley 2012-06-11 12:17:24 EDT
The line wrap was right after the q in the "quiet" parameter just before
the boot_delay=100.

The cursor continued to move even after it stopped erasing characters from
the screen, so what I saw was something like:

long line... q\
uiet^boot_del

Where the ^ indicates the cursor position.

I didn't try doing a lot of other editing this time, I suspect the fact that
I did try doing a lot of cursor movement and trying different things the first
time is what got my system frozen :-).
Comment 6 Mads Kiilerich 2012-06-11 18:18:34 EDT
I'm sorry - that build did not contain the patches I thought it did.

Please try again with this snapshot in an unofficial scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4152623 grub2-2.0-0.37.beta6.4462.fc17
Comment 7 Tom Horsley 2012-06-12 08:03:55 EDT
Yep. The grub2-2.0-0.37.beta6.4462.fc17 does indeed seem to fix the editing problems. I could delete characters through the line wrap, then type more characters to make the line wrap again, and everything worked correctly.
Comment 8 Fedora End Of Life 2013-07-03 22:38:02 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-08-01 04:55:42 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.