Bug 832083

Summary: missing utrace / uprobes
Product: [Fedora] Fedora Reporter: Frank Ch. Eigler <fche>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 17CC: anton, gansalmon, itamar, jistone, jonathan, kernel-maint, lberk, lwang, madhu.chinakonda, mjw, onestero, rrakus, scottt.tw, tcallawa
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-30 21:59:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Frank Ch. Eigler 2012-06-14 13:27:11 UTC
Several users are reporting regressions evident in systemtap due to the recent f17 3.4.0 rebase, which removed the utrace patch but didn't replace it with the 3.5-bound uprobes.  Please consider correcting this regression, and ideally not by delaying for a 3.5-based rebase some months from now.

Comment 1 Frank Ch. Eigler 2012-06-15 16:55:04 UTC
*** Bug 832533 has been marked as a duplicate of this bug. ***

Comment 2 Mark Wielaard 2012-06-20 08:35:31 UTC
Urgh, this was the reason I didn't upgrade from F16 to F17. But now the same issue has hit F16 with the latest kernel update to 3.4.2-1.fc16.x86_64

user-space facilities not available without kernel CONFIG_UTRACE or CONFIG_TRACEPOINTS/CONFIG_ARCH_SUPPORTS_UPROBES/CONFIG_UPROBES

Comment 3 Josh Boyer 2012-06-22 15:52:41 UTC
Anton provided backports of the relevant uprobes changes from upstream and -tip.  Those have been committed to Fedora git.

Comment 4 Fedora Update System 2012-06-27 00:09:10 UTC
kernel-3.4.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.4.4-3.fc17

Comment 5 Fedora Update System 2012-06-27 00:11:57 UTC
kernel-3.4.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.4-3.fc16

Comment 6 Fedora Update System 2012-06-28 03:28:24 UTC
Package kernel-3.4.4-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.4.4-3.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9988/kernel-3.4.4-3.fc17
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-06-30 21:59:48 UTC
kernel-3.4.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-07-05 23:51:02 UTC
kernel-3.4.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.4.4-4.fc16

Comment 9 Fedora Update System 2012-07-08 20:52:10 UTC
kernel-3.4.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.