Bug 83260

Summary: First application launches after reboot extremely slow
Product: [Retired] Red Hat Linux Reporter: Heikki Toivonen <heikki>
Component: metacityAssignee: Havoc Pennington <hp>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Heikki Toivonen 2003-02-01 00:07:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
After reboot, launching any application for the first time is excruciatingly
slow. For example, launching htmlview takes 40-45 seconds. This only happens
with the default window manager. If I try under KDE or WindowMaker htmlview
launches in about 6 seconds.

After an application has been started at least once, they usually start again in
less than 5 seconds, even if I log out in the meanwhile.

My hardware: DELL Latitude (800-something series? 1600x1200 display) 1.8GHz/1GB
NVIDIA GeForce 4 Mobile Go(?), dual boot Win2k/RH 8.0 with 10GB on Linux
partition, 0.5-2.5% disc fragmentation. I have seen other people with supposedly
the exact same hardware and software and no problems, and also people with other
hardware facing the same problems I have.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Reboot
2. Login with Gnome
3. Launch htmlview and measure how long it takes.
4. Reboot
5. Login with KDE or WindowMaker
6. Launch htmlview and measure how long it takes

Actual Results:  Under Gnome launching htmlview takes almost 10 times longer
than on other window managers.

Expected Results:  Launching htmlview should take about the same time.

Additional info:

I have tried without SWAP, with default SWAP, with local user and NIS, have
tried different display drivers (default 'vesa' and NVIDIA). Tried with somewhat
configured installation, and almost default workstation installation (only added
some things, nothing removed).

Comment 1 Heikki Toivonen 2003-02-01 00:29:57 UTC
This is probably a duplicate of bug 73661 (bug 77401 is probably also a dupe of
that). When I killed magicdev process htmlview started up as fast as under KDE.

Comment 2 Havoc Pennington 2003-02-01 00:37:41 UTC

*** This bug has been marked as a duplicate of 73661 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.