Bug 83405

Summary: DAC960 does not implement BLKPG_ADD_PARTITION
Product: [Retired] Red Hat Linux Reporter: Matt Wilson <msw>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-24 17:07:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578, 80767    

Description Matt Wilson 2003-02-04 00:57:14 UTC
Needs more cases in the generic passup.  In fact, one would think it would be
default:

    case BLKRAGET:
    case BLKRASET:
    case BLKFLSBUF:
    case BLKBSZGET:
    case BLKBSZSET:
      return blk_ioctl(Inode->i_rdev, Request, Argument);

Comment 1 Ben LaHaise 2003-02-04 02:42:47 UTC
fix committed to cvs

Comment 2 Brian Brock 2003-06-24 17:07:26 UTC
driver appears to have changed a lot.  Can't verify specific fix without more
detail, but also haven't seen related complaints since fix was committed to CVS.
 closing.