Bug 834076

Summary: Fedora 17 does not install via bootable media on new (Mid-2012) MacBook Pro (9,2)
Product: [Fedora] Fedora Reporter: Brian Smith <bcs296>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 17CC: bugzilla, ebassi, eroux, gansalmon, g.kaviyarasu, ian.dick01, info, itamar, jensk.maps, jonathan, joshua, kernel-maint, madhu.chinakonda, netllama, robin, ronan.forker, sog, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Mac OS   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-08 11:19:09 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
call trace 1
none
call trace 2
none
call trace 3 none

Description Brian Smith 2012-06-20 14:33:17 EDT
Description of problem:
F17 cannot be installed on the newly released MacBook Pro models (Mid-2012). The installer freezes after selecting an installation option at the Fedora boot menu.

I have tried this with the F17 Live CD and the Full DVD. I have the 13" MacBook Pro with Intel Core i5 Ivy Bridge processor and Intel HD 4000 integrated graphics. I have also confirmed with another user on Fedoraforum that he sees the same result on a new MacBook Air (basically the same internal hardware - Ivy Bridge Core i5/i7 with Intel HD 4000 graphics).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert F17 Live CD or Full DVD Installation
2. When booting the MacBook Pro, hold alt/option key to bring up boot device menu
3. Select Fedora as the boot option
3. Select one of the boot options from Fedora menu and press Enter
  
Actual results:
Installer freezes. Optical drive stops spinning and device must be hard reset to get it to boot up again.

Expected results:
Installer should begin the installation process.

Additional info:
Comment 1 Chris Lumens 2012-06-22 10:56:09 EDT
Mysterious lockups are frequently the symptom of a kernel problem.  Reassigning in the hopes that they'll know how to go about debugging this.
Comment 2 Brian Smith 2012-06-22 11:48:43 EDT
It looks like adding noapic to the boot command gets the installation process a little further along. 

http://forums.fedoraforum.org/showthread.php?t=281038
Comment 3 Chris Murphy 2012-06-27 14:42:50 EDT
Does the same problem occur when in step 3 (the first step 3) you select Windows as the boot option? Can you report the version of EFI compliance (using shellx64.efi or rEFIt or rEFInd)?
Comment 4 Robin Stocker 2012-06-27 16:07:11 EDT
Created attachment 594859 [details]
call trace 1

Here are some call traces (I don't know if they're useful). They are all from different boots. One time the boot actually succeeded to GNOME.

The kernel command line was with "rhgb" and "quiet" removed and "noapic" added.
Comment 5 Robin Stocker 2012-06-27 16:09:06 EDT
Created attachment 594860 [details]
call trace 2
Comment 6 Robin Stocker 2012-06-27 16:09:25 EDT
Created attachment 594861 [details]
call trace 3
Comment 7 Robin Stocker 2012-07-01 11:28:02 EDT
By the way, kernel 3.3.4-5 works with the boot option "nointremap". 3.4.3-1 doesn't though.
Comment 8 Eugene Roux 2012-07-05 11:13:17 EDT
So far it's been a complete wash for me on my 2012 MacBook Pro 15”

Fortunately Fedora seems to run just fine within a VM under Fusion.
Comment 9 Jeff 2012-07-12 12:18:45 EDT
Same problem occurs on 2012 MacBook Air model
Comment 10 Jens Knutson 2012-07-12 19:07:03 EDT
FWIW, I used the F17 boot.iso to make a USB flash drive installer, and that worked flawlessly on my 2012 MacBook Air 13".  If anyone working on this bug wants some diagnostic output (lspci, dmesg, whatever) to help fix this, please let me know.
Comment 11 Jens Knutson 2012-07-12 19:08:14 EDT
Sorry, forgot to add I used the i686 install.
Comment 12 Jeff 2012-07-20 09:43:12 EDT
(In reply to comment #11)
> Sorry, forgot to add I used the i686 install.

Thanks Jens, also got F17 working using the i686 Live ISO however needed PAE to address all 8GB of RAM.
Comment 13 joshua 2012-08-13 18:37:30 EDT
I got my 2012 Macbook Pro 15 Retina laptop working with F17 x86_64 by booting to the netboot CD, and appending noapic to the kernel command line.

post-install video is another matter... but at least it installs