Bug 83536

Summary: /usr/share/redhat-config-xfree86/xconf.py improper Syntax.
Product: [Retired] Red Hat Linux Reporter: Jason Montleon <jason>
Component: redhat-config-xfree86Assignee: Brent Fox <bfox>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: mharris
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jason Montleon 2003-02-05 13:47:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
I tried to run the Display under system settings as a user.  I was prompted for
root password and supplied it.  After that nothing happened.  I tried again and
was not even prompted for the root password.  Rebooted and still was not even
prompted for the root password before the program exited out.  I tried running
it from the command line and received the message:

[root@2kcomm root]# redhat-config-xfree86
  File "/usr/share/redhat-config-xfree86/xconf.py", line 357
    current_card_driver = current_card.getCardData()["DRIVER"]
                      ^
SyntaxError: invalid syntax

(the carat was under the r in driver on the command line, other than that the
layout is fairly identical, as it is a cut and paste)

It appears that the line above that (line 356), 
print _("Trying with card:", current_card.getCardData()["NAME"])

was missing the end parenthisis, which I added, and was then able to run
redhat-config-xfree86 with expected results.

I never manually manipulated the file previous to this attempt to run the program.  

Version-Release number of selected component (if applicable):

How reproducible:
Couldn't Reproduce

Additional info:

Comment 1 Mike A. Harris 2003-02-05 14:21:29 UTC

*** This bug has been marked as a duplicate of 82710 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.