This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 836684

Summary: [abrt] gnome-boxes-3.4.3-1.fc17: __memcpy_ssse3_back: Process /usr/bin/gnome-boxes was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Bahtiar `kalkin` Gadimov <bahtiar>
Component: libvirtAssignee: Martin Kletzander <mkletzan>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: berrange, brian, cfergeau, clalancette, crobinso, dallan, dougsland, itamar, jforbes, jyang, laine, levko.lb, libvirt-maint, logical421, marcandre.lureau, mprivozn, veillard, virt-maint, zali
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:3a7436221596727eb207084699068fc7d891add3
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-01 16:55:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
File: maps
none
File: dso_list
none
File: build_ids
none
abrt folder with coredump none

Description Bahtiar `kalkin` Gadimov 2012-06-29 19:15:54 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gnome-boxes
crash_function: __memcpy_ssse3_back
executable:     /usr/bin/gnome-boxes
kernel:         3.4.3-1.fc17.x86_64
pid:            2556
pwd:            /home/kalkin
time:           Di 26 Jun 2012 20:06:07 CEST
uid:            1000
username:       kalkin
var_log_messages: Jun 26 20:06:08 st015 abrt[2664]: Saved core dump of pid 2556 (/usr/bin/gnome-boxes) to /var/spool/abrt/ccpp-2012-06-26-20:06:07-2556 (129077248 bytes)
xsession_errors: 

backtrace:      Text file, 161777 bytes
build_ids:      Text file, 6888 bytes
dso_list:       Text file, 16218 bytes
maps:           Text file, 80821 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/kalkin/6

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x146d80 __memcpy_ssse3_back libc.so.6 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x1339ab - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x124022 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x12505d - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x125801 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x126a4b - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x12723b - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x109d58 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x10f143 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0xde88b virDomainGetInfo libvirt.so.0 -
:0f959ca1e748b410792c45376f924aa3eb9fbeda 0xad37 gvir_domain_get_info libvirt-gobject-1.0.so.0 -
:0f959ca1e748b410792c45376f924aa3eb9fbeda 0xadd2 - libvirt-gobject-1.0.so.0 -
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f 0x6cd5e - libgio-2.0.so.0 -
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f 0x5c11e - libgio-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6ab42 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6a345 - libglib-2.0.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:XDG_VTNR=3
:XDG_SESSION_ID=6
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:TERM=dumb
:SHELL=/bin/zsh
:XDG_SESSION_COOKIE=049055c4f6fd45f52ad3f13b0000008f-1340733618.810907-203853938
:GNOME_KEYRING_CONTROL=/run/user/kalkin/keyring-KFD4Jf
:IMSETTINGS_MODULE=none
:USER=kalkin
:USERNAME=kalkin
:DESKTOP_SESSION=gnome
:PATH=/home/kalkin/.rvm/gems/ruby-1.9.3-p125@ROR-Prototype/bin:/home/kalkin/.rvm/gems/ruby-1.9.3-p125@global/bin:/home/kalkin/.rvm/rubies/ruby-1.9.3-p125/bin:/home/kalkin/.rvm/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/home/kalkin/bin:/usr/local/sbin:/usr/sbin
:QT_IM_MODULE=xim
:PWD=/home/kalkin
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1946
:GDMSESSION=gnome
:SHLVL=0
:HOME=/home/kalkin
:XDG_SEAT=seat0
:LOGNAME=kalkin
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zPWFyEuDP5,guid=27f8bdfc15c0ed2d49d7aadc00000098
:WINDOWPATH=3
:DISPLAY=:1
:XDG_RUNTIME_DIR=/run/user/kalkin
:XAUTHORITY=/var/run/gdm/auth-for-kalkin-8PHZoR/database
:OLDPWD=/home/kalkin
:HISTCONTROL=ignoredups
:MAIL=/var/spool/mail/kalkin
:HOSTNAME=st015
:HISTSIZE=1000
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:QT_GRAPHICSSYSTEM_CHECKED=1
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:QTLIB=/usr/lib64/qt-3.3/lib
:rvm_prefix=/home/kalkin
:rvm_path=/home/kalkin/.rvm
:__array_start=1
:rvm_bin_path=/home/kalkin/.rvm/bin
:escape_flag=1
:_first=1
:_second=2
:'rvm_version=1.12.1 (master)'
:rvm_env_string=ruby-1.9.3-p125@ROR-Prototype
:rvm_ruby_string=ruby-1.9.3-p125
:RUBY_VERSION=ruby-1.9.3-p125
:GEM_HOME=/home/kalkin/.rvm/gems/ruby-1.9.3-p125@ROR-Prototype
:GEM_PATH=/home/kalkin/.rvm/gems/ruby-1.9.3-p125@ROR-Prototype:/home/kalkin/.rvm/gems/ruby-1.9.3-p125@global
:MY_RUBY_HOME=/home/kalkin/.rvm/rubies/ruby-1.9.3-p125
:IRBRC=/home/kalkin/.rvm/rubies/ruby-1.9.3-p125/.irbrc
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1950,unix/unix:/tmp/.ICE-unix/1950
:GPG_AGENT_INFO=/run/user/kalkin/keyring-KFD4Jf/gpg:0:1
:SSH_AUTH_SOCK=/run/user/kalkin/keyring-KFD4Jf/ssh
:LC_TIME=de_DE.utf8
:LC_NUMERIC=de_DE.utf8
:LC_MONETARY=de_DE.utf8
:LC_MEASUREMENT=de_DE.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-boxes.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2556
:DESKTOP_STARTUP_ID=gnome-shell-2162-st015-gnome-boxes-2_TIME444186

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 61943                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       61943                61943                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/kalkin/.xsession-errors
:pos:	27274
:flags:	0102002
:2:/home/kalkin/.xsession-errors
:pos:	27274
:flags:	0102002
:3:socket:[32013]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[34443]
:pos:	0
:flags:	02004002
:6:/dev/dri/card0
:pos:	0
:flags:	0100002
:7:/dev/urandom
:pos:	0
:flags:	02100000
:8:socket:[34870]
:pos:	0
:flags:	02000002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[32014]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:13:socket:[30644]
:pos:	0
:flags:	02004002
:14:/home/kalkin/.cache/tracker/meta.db
:pos:	3087360
:flags:	02100000
:15:/home/kalkin/.cache/tracker/meta.db-wal
:pos:	1080
:flags:	02100002
:16:/home/kalkin/.cache/tracker/meta.db-shm
:pos:	0
:flags:	0100002
:17:anon_inode:inotify
:pos:	0
:flags:	02004000
:18:/dev/urandom
:pos:	0
:flags:	02100000
:19:socket:[34883]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: fd38eec9-af18-4428-84c4-be214724752d
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5582.03
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2801
:System Memory: 7764
:System Swap: 7627
:Vendor: LENOVO
:System: 4296CTO ThinkPad X220 Tablet
:Form factor: Notebook
:Kernel: 3.4.3-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8667) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(32902:294:6058:8667) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7192:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8667) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7202:6058:8667) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4332:33142:4332:33173) pci, rtl8192ce, NETWORK, RTL8188CE 802.11b/g/n WiFi Adapter
:(4480:59427:6058:8667) pci, sdhci-pci, BASE, N/A
:(32902:7171:6058:8667) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:6058:8667) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8667) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8667) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8667) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg--st015-root / ext4 4096 4096 12190403 9765167 9643153 3055616 2823131 2823131
:/dev/sda1 /boot ext3 1024 1024 493540 401290 375690 128016 127643 127643
:/dev/mapper/vg--st015-home /home btrfs 4096 4096 24413184 8357789 6150823 0 0 0
:
Comment 1 Bahtiar `kalkin` Gadimov 2012-06-29 19:16:01 EDT
Created attachment 595385 [details]
File: backtrace
Comment 2 Bahtiar `kalkin` Gadimov 2012-06-29 19:16:04 EDT
Created attachment 595386 [details]
File: maps
Comment 3 Bahtiar `kalkin` Gadimov 2012-06-29 19:16:06 EDT
Created attachment 595387 [details]
File: dso_list
Comment 4 Bahtiar `kalkin` Gadimov 2012-06-29 19:16:08 EDT
Created attachment 595388 [details]
File: build_ids
Comment 5 Zeeshan Ali 2012-06-29 19:45:12 EDT
The crash is happening deeep in the libvirt territory so re-assigning.
Comment 6 Martin Kletzander 2012-07-03 09:52:48 EDT
Hello,

does this happen all the time or just one? Do you know how to reproduce it? Or do you have the coredump available?

Thanks,
Martin
Comment 7 Bahtiar `kalkin` Gadimov 2012-07-07 20:46:15 EDT
(In reply to comment #6)
> Hello,
> 
> does this happen all the time or just one?

just one time. But I'm using virt-manager now (for other reasons), so i don't know if it happens often. 

> Do you know how to reproduce it?

No, sorry.

> Or do you have the coredump available?

I generated the bug report with abrt. It's everything that i have.
Comment 8 Martin Kletzander 2012-07-16 05:40:53 EDT
According to the message, the coredump should be in
/var/spool/abrt/ccpp-2012-06-26-20:06:07-2556

Please have a look because when I went through the code thoroughly and I didn't find any leak in the qemu driver, nor in the API.

Otherwise I'll have to close this bug.

Thanks
Comment 9 Mads Kiilerich 2012-08-09 10:05:31 EDT
Created attachment 603261 [details]
abrt folder with coredump

abrt reported that I got a duplicate - here is the requested information
Comment 10 Cole Robinson 2012-10-01 16:55:21 EDT
Given that this is in the RPC layer, I think the backported RPC fixes in libvirt 0.9.11.5 may have fixed this. Closing as CURRENTRELEASE. If someone else hits this hopefully abrt will dup it here.
Comment 11 Cole Robinson 2012-10-01 17:47:39 EDT
*** Bug 822602 has been marked as a duplicate of this bug. ***
Comment 12 Cole Robinson 2012-10-01 17:47:47 EDT
*** Bug 836683 has been marked as a duplicate of this bug. ***
Comment 13 Cole Robinson 2012-10-01 17:48:31 EDT
*** Bug 846313 has been marked as a duplicate of this bug. ***
Comment 14 Cole Robinson 2012-10-01 17:49:20 EDT
*** Bug 846713 has been marked as a duplicate of this bug. ***
Comment 15 Cole Robinson 2012-10-01 17:50:19 EDT
*** Bug 815432 has been marked as a duplicate of this bug. ***
Comment 16 Cole Robinson 2012-10-19 15:46:20 EDT
*** Bug 848513 has been marked as a duplicate of this bug. ***