Bug 837415

Summary: java-1.7.0-openjdk is FTBFS on ARM rawhide
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: java-1.7.0-openjdkAssignee: Deepak Bhole <dbhole>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: urgent    
Version: rawhideCC: dbhole, jvanek, omajid
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-03 15:57:46 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    

Description Peter Robinson 2012-07-03 15:48:51 EDT
version failing: java-1.7.0-openjdk-1.7.0.3-2.2.1.fc18.8 (and fc18.7)

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=939997

Last known good build was java-1.7.0-openjdk-1.7.0.3-2.1.fc18.7

relevant bit:

g++ -DLINUX -D_GNU_SOURCE -DCC_INTERP -DZERO -DTARGET_ARCH_NYI_6939861=1 -DARM -DZERO_LIBARCH=\"arm\" -DPRODUCT -I. -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/precompiled -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/cpu/zero/vm -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/os_cpu/linux_zero/vm -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm -I/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/os/posix/vm -I../generated -DHOTSPOT_RELEASE_VERSION="\"23.0-b21\"" -DHOTSPOT_BUILD_TARGET="\"product\"" -DHOTSPOT_BUILD_USER="\"mockbuild\"" -DHOTSPOT_LIB_ARCH=\"arm\" -DHOTSPOT_VM_DISTRO="\"OpenJDK\"" -DTARGET_OS_FAMILY_linux -DTARGET_ARCH_zero -DTARGET_ARCH_MODEL_zero -DTARGET_OS_ARCH_linux_zero -DTARGET_OS_ARCH_MODEL_linux_zero -DTARGET_COMPILER_gcc -I/usr/lib/libffi-3.0.10/include    -fpic -fno-rtti -fno-exceptions -D_REENTRANT -fcheck-new -fvisibility=hidden  -pipe -g -O3 -fno-strict-aliasing  -gstabs -DVM_LITTLE_ENDIAN -DINCLUDE_TRACE -Werror -Wpointer-arith -Wsign-compare    -c -MMD -MP -MF ../generated/dependencies/cppInterpreter_zero.o.d -o cppInterpreter_zero.o /builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp 
/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp: In static member function 'static void CppInterpreter::process_method_handle(oop, Thread*)':
/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp:817:7: error: 'get_ek_bound_mh_info' is not a member of 'MethodHandles'
/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp:965:7: error: 'get_ek_adapter_opt_swap_rot_info' is not a member of 'MethodHandles'
make[6]: *** [cppInterpreter_zero.o] Error 1
make[6]: *** Waiting for unfinished jobs....
make[6]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/build/linux-arm/hotspot/outputdir/linux_arm_zero/product'
make[5]: *** [the_vm] Error 2
make[5]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/build/linux-arm/hotspot/outputdir/linux_arm_zero/product'
make[4]: *** [productzero] Error 2
make[4]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/build/linux-arm/hotspot/outputdir'
make[3]: *** [generic_buildzero] Error 2
make[3]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/make'
make[2]: *** [productzero] Error 2
make[2]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk/openjdk/hotspot/make'
make[1]: *** [hotspot-build] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/java-1.7.0-openjdk/openjdk'
make: *** [build_product_image] Error 2
Comment 1 Deepak Bhole 2012-07-03 15:57:46 EDT

*** This bug has been marked as a duplicate of bug 837403 ***