Bug 838476

Summary: perl-DateTime is too old
Product: Red Hat Enterprise Linux 7 Reporter: Petr Pisar <ppisar>
Component: perl-DateTimeAssignee: perl-maint-list
Status: CLOSED CURRENTRELEASE QA Contact: Martin Kyral <mkyral>
Severity: high Docs Contact:
Priority: unspecified    
Version: 7.0CC: mkyral
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: http://search.cpan.org/~drolsky/DateTime/
Whiteboard:
Fixed In Version: perl-DateTime-0.77-1.el7 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 838120
: 838480 (view as bug list) Environment:
Last Closed: 2014-03-07 09:38:05 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Petr Pisar 2012-07-09 04:33:27 EDT
+++ This bug was initially created as a clone of Bug #838120 +++

Fedora delivers version 0.70 which is too old.

For example it does not implement 2012-07 leap second which has been added by upstream in version 0.71 on 2012-01-05. It can result in faulty time arithmetics now.

It's shame Fedora does not deliver current version of such impotant package demanding regular updates. Upstream changelog:

0.76   2012-07-01

- The DateTime->subtract method ignored the end_of_month parameter. Patch by
  Chris Reinhardt. RT #77844.


0.75   2012-06-11

- The epoch for years 1-999 was broken because Time::Local is "clever". A pox
  on all clever APIs, I say! Reported by Christian Hansen. RT #77719.

- Shut up compilation warning from 5.17.x. Reported by Tom Wyant. RT #77490.


0.74   2012-03-22

- Small packaging fix for metacpan's benefit. No need to upgrade.


0.73   2012-03-17

- Change tests to work with Zefram's entirely rebuilt DateTime::TimeZone
  distribution, which will replace the current implementation. Patch by
  Zefram. RT #75757.


0.72   2012-01-05

- Remove Test::DependentModules from the dep list. This is used by some
  author-only tests. Reported by Zefram.


0.71   2012-01-05

- There will be a new leap second on June 30, 2012.

--- Additional comment from iarnell@gmail.com on 2012-07-06 17:59:53 GMT ---

[...]

And Petr, how about cloning this for RHEL? It's an even bigger shame that Red Hat delivers an even more outdated version of this package (and more importantly, DateTime::TimeZone) demanding regular updates.
-------

RHEL-7 is affected (perl-DateTime-0.70-3.el7).