Bug 838941 (CVE-2012-3402)

Summary: CVE-2012-3402 gimp (PSD plug-in): Heap-buffer overflow by decoding certain PSD headers
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: NEW --- QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: mjc, nphilipp, security-response-team
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=moderate,public=20120820,reported=20120702,source=redhat,cvss2=6.8/AV:N/AC:M/Au:N/C:P/I:P/A:P,rhel-5/gimp=affected,rhel-6/gimp=notaffected,fedora-all/gimp=notaffected,cwe=CWE-122[auto]
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 714127, 714128    
Bug Blocks: 714114    
Attachments:
Description Flags
Patch to fix CVEs 2009-3909 and 2012-3402 none

Description Jan Lieskovsky 2012-07-10 09:28:05 EDT
A heap-based buffer overflow flaw was found in the way Adobe Photoshop(tm) PSD plug-in of Gimp, the GNU Image Manipulation Program, performed decoding of headers, when loading certain Adobe Photoshop image files. A remote attacker could provide a specially-crafted PSD image file that, when opened in Gimp would lead to PSD plug-in crash or, potentially, arbitrary code execution with the privileges of the user running gimp executable.

This issue was found by Jan Lieskovsky of the Red Hat Security Response Team
Comment 3 Jan Lieskovsky 2012-07-11 11:52:27 EDT
The CVE identifier of CVE-2012-3402 has been assigned to this issue.
Comment 4 Nils Philippsen 2012-08-08 11:35:00 EDT
Created attachment 603059 [details]
Patch to fix CVEs 2009-3909 and 2012-3402
Comment 7 errata-xmlrpc 2012-08-20 09:45:12 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2012:1181 https://rhn.redhat.com/errata/RHSA-2012-1181.html