Bug 839142

Summary: Review Request: python-urllib2_kerberos - Kerberos over HTTP Negotiate/SPNEGO support for urllib2
Product: [Fedora] Fedora Reporter: Tomas Dabašinskas <tdabasin>
Component: Package ReviewAssignee: Matěj Cepl <mcepl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bleanhar, mcepl, notting, package-review, steve.traylen
Target Milestone: ---Flags: mcepl: fedora‑review+
limburgher: fedora‑cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-28 19:28:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 819687    

Description Tomas Dabašinskas 2012-07-11 01:43:03 EDT
Spec URL: https://github.com/downloads/T0MASD/python-rtkit/python-urllib2_kerberos.spec
SRPM URL: https://github.com/downloads/T0MASD/python-rtkit/python-urllib2_kerberos-0.1.6-6.el6.src.rpm
Description: urllib2 plugin for kerberos authentication.
Fedora Account System Username: tdabasin

Please note that source is old and does not include documentation or separate license file
Comment 1 Brenton Leanhardt 2012-07-26 14:33:43 EDT
From the looks of the changelog this is a deprecated package.  While it's not listed formally on http://fedoraproject.org/wiki/Deprecated_packages you can see from https://admin.fedoraproject.org/pkgdb/acls/name/python-urllib2_kerberos that the status is deprecated and that it's orphaned in fedora-devel.  In many cases this is for good reason.  If a packages isn't being maintained anymore it's not appropriate for Fedora.
 
What you'll need to do from here is contact the previous package maintainers and find out why it's in this state.  You should also attempt to contact the upstream maintainer.

Just to be clear, in the case where upstream is unresponsive you need to make sure you are willing to maintain not only the packaging but also the library itself (ie, fixing critical bugs).  Any evidence of your qualifications for doing this would go a long way to encouraging the Fedora community to reinstate this package.  For more information see:
http://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers
Comment 2 Tomas Dabašinskas 2012-07-29 19:32:59 EDT
Matěj,
I'm trying to get python-urllib2_kerberos back to Fedora packages repo. Brenton has advised me to get in touch with you and find out the reason why package was depreciated. There's a note by Bill Nottingham <notting@redhat.com> in dead.package[1] saying: "This package was retired due to no active owner on 2010-08-27". Is there an alternative to using python-urllib2_kerberos? If not I'm happy to to maintain the package. 


[1] http://pkgs.fedoraproject.org/gitweb/?p=python-urllib2_kerberos.git;a=blob;f=dead.package
Comment 3 Matěj Cepl 2012-07-30 12:02:17 EDT
Taking the review.
Comment 4 Matěj Cepl 2012-07-30 12:41:01 EDT
Legend: + = PASSED, - = FAILED, 0 = Not Applicable

+ MUST: rpmlint must be run on every package. The output should be posted in
the review

wycliff:tmp $ rpmlint -i *.src.rpm noarch/*.rpm
python-urllib2_kerberos.noarch: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

2 packages and 0 specfiles checked; 0 errors, 1 warnings.
wycliff:tmp $ 

Upstream package doesn't contain any special documentation, so this warning can be ignored, packagers are not required to write documentation themselves. It would however be good to provide at least some examples how to incorporate this module into normal Python script (or at least a reference to some web document describing it). That's however, not a requirement for this packaging review.

+ MUST: package named according to the Package Naming Guidelines
+ MUST: The spec file name must match the base package %{name}
+ MUST: The package must meet the Packaging Guidelines .

This is possible as well:

# Remove "#!/usr/bin/python\n"
tail -n +2 urllib2_kerberos.py >patched-urllib2_kerberos.py
mv patched-urllib2_kerberos.py urllib2_kerberos.py

but I would prefer something more conservative (e.g.,
sed -i -e '/^#!\s*\/.*bin\/.*python/d' urllib2_kerberos.py

or something even better). But, again, that's just a nit-pick not a breach of the packaging requirements.

+ MUST: The package licensed with a Fedora approved license and meets the
Licensing Guidelines
+ MUST: The License field in the package spec file matches the actual
license
APL2
+ MUST: If (and only if) the source package includes the text of the license(s)
in its own file, then that file, containing the text of the license(s) for the
package must be included in %doc.
License file is not included in the upstream package.
+ MUST: The spec file must be written in American English.
+ MUST: The spec file for the package MUST be legible.
+ MUST: The sources used to build the package must match the upstream
source, as provided in the spec URL. Reviewers should use md5sum for this task
MD5: 9a22d5d243103e17ca0ccf64b51f54ec
+ MUST: The package successfully compiles and builds into binary rpms on at
least one primary architecture - build in koji, no problems
0 MUST: If the package does not successfully compile, build or work on an
architecture, then those architectures should be listed in the spec in
ExcludeArch
+ MUST: All build dependencies must be listed in BuildRequires, except for any
that are listed in the exceptions section of the Packaging Guidelines
Build in koji (http://koji.fedoraproject.org/koji/taskinfo?taskID=4342775)
0 MUST: The spec file handles locales properly. This is done by using the
%find_lang macro
No locales are present.
0 MUST: Every binary RPM package (or subpackage) which stores shared library
files (not just symlinks) in any of the dynamic linker's default paths, must
call ldconfig in %post and %postun.
No libraries provided.
+ MUST: Packages must NOT bundle copies of system libraries
0 MUST: If the package is designed to be relocatable, the packager must state
this fact in the request for review, along with the rationalization for
relocation of that specific package. Without this, use of Prefix: /usr is
considered a blocker
+ MUST: Package must own all directories that it creates. If it does not create
a directory that it uses, then it should require a package which does create
that directory
+ MUST: Package must not list a file more than once in the spec file's %files
listings
+ MUST: Each package must consistently use macros
+ MUST: The package must contain code, or permissible content
0 MUST: Large documentation files must go in a -doc subpackage
0 MUST: If a package includes something as %doc, it must not affect the runtime
of the application
0 MUST: Header files must be in a -devel package
0 MUST: Static libraries must be in a -static package
0 MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'
0 MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1),
then library files that end in .so (without suffix) must go in a -devel package
0 MUST: devel packages must require the base package using a fully versioned
dependency: Requires: %{name} = %{version}-%{release}
+ MUST: Packages must NOT contain any .la libtool archives, these must be
removed in the spec if they are built
0 MUST: Packages containing GUI applications must include a %{name}.desktop
file, and that file must be properly installed with desktop-file-install in the
%install section
+ MUST: Packages must not own files or directories already owned by other
packages
+ MUST: All filenames in rpm packages must be valid UTF-8

Please consider suggested enhancements, but otherwise this package is

APPROVED
Comment 5 Tomas Dabašinskas 2012-08-01 21:52:26 EDT
Matěj, many thanks for the feedback, I anticipate to fix your suggestions for next rebuild. Can you please tell me what is the procedure from now?
Comment 7 Tomas Dabašinskas 2012-08-05 20:38:45 EDT
Package Change Request
======================
Package Name: python-urllib2_kerberos
New Branches: f16 f17 el6
Owners: tdabasin
InitialCC: 

old package git url: http://pkgs.fedoraproject.org/cgit/python-urllib2_kerberos.git/ currently retired, please reinstate
Comment 8 Kevin Fenzi 2012-08-07 20:09:53 EDT
Matěj: For folks that need sponsoring, the review should be done by a sponsor. ;) 

This is a pretty simple package, but I can go ahead and sponsor you. 

If you have any questions please contact me... I'll let Jason review your other submission when he gets back.
Comment 9 Jon Ciesla 2012-08-08 08:27:16 EDT
Git done (by process-git-requests).

Unorphaned devel.
Comment 10 Fedora Update System 2012-08-19 21:53:59 EDT
python-urllib2_kerberos-0.1.6-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-6.fc18
Comment 11 Fedora Update System 2012-08-19 21:56:03 EDT
python-urllib2_kerberos-0.1.6-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-6.fc17
Comment 12 Fedora Update System 2012-08-19 22:04:37 EDT
python-urllib2_kerberos-0.1.6-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-6.fc16
Comment 13 Fedora Update System 2012-08-19 23:57:34 EDT
python-urllib2_kerberos-0.1.6-6.fc18 has been pushed to the Fedora 18 testing repository.
Comment 14 Fedora Update System 2012-08-28 19:28:03 EDT
python-urllib2_kerberos-0.1.6-6.fc16 has been pushed to the Fedora 16 stable repository.
Comment 15 Fedora Update System 2012-08-28 19:28:24 EDT
python-urllib2_kerberos-0.1.6-6.fc17 has been pushed to the Fedora 17 stable repository.
Comment 16 Fedora Update System 2012-09-17 17:56:01 EDT
python-urllib2_kerberos-0.1.6-6.fc18 has been pushed to the Fedora 18 stable repository.
Comment 17 Steve Traylen 2014-09-09 08:28:00 EDT
Package Change Request
======================
Package Name: pkgname
New Branches: epel7
Owners: stevetraylen
Comment 18 Steve Traylen 2014-09-09 08:28:26 EDT
Package Change Request
======================
Package Name: python-urllib2_kerberos
New Branches: epel7
Owners: stevetraylen
Comment 19 Jon Ciesla 2014-09-09 08:59:32 EDT
Git done (by process-git-requests).