Bug 840051

Summary: Rebase request for crash utility RHEL6.4 errata
Product: Red Hat Enterprise Linux 6 Reporter: Dave Anderson <anderson>
Component: crashAssignee: Dave Anderson <anderson>
Status: CLOSED ERRATA QA Contact: Guangze Bai <gbai>
Severity: high Docs Contact:
Priority: high    
Version: 6.4CC: caiqian, jbrouer, yshao
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: crash-6.1.0-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-21 03:34:13 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Dave Anderson 2012-07-13 10:59:07 EDT
Description of problem:

The RHEL6.4 errata version of crash should be rebased to the most recent
upstream version of the crash utility.

It is far more efficient, and far safer, to rebase to the upstream 
version than to attempt to selectively backport the patches required for
the current set of bugzillas requested for RHEL6.4.  More importantly,
the new features and other fixes that have been applied to the upstream 
version make the tool significantly more useful than the current RHEL6 
version.

It should also be noted that Fedora 18, and therefore RHEL7, kernels
are incompatible with the current RHEL6 version of the crash utility.
This is due to fundamental changes in the recent upstream kernel, such
as the 3.5 change to the printk log buffer format, which causes the 
crash session to fail during initialization, the 3.3 rework of the VFS
subsystem which cause several key commands to fail, and a number of other 
smaller changes that affect command behavior with the later kernels. 

As the owner and upstream maintainer, one of my primary goals is, and
always has been, to maintain backwards-compatibility whenever new fixes
or features are applied.  Therefore the risk of regression is less with a
rebase than it would be with selective backports because the RHEL6.4
bugzilla-requested fixes are based upon the state of the upstream version. 

It should be noted that nothing goes into the upstream version without
my approval, and my testing.  I perform all my testing on RHEL6 systems,
and test changes against a sample set of RHEL3, RHEL4, RHEL5, RHEL6, 
upstream and Fedora kernel crash dumps.

Details regarding recent fixes, features and enhancements can be found in:

  http://people.redhat.com/anderson/crash.changelog.html

Version-Release number of selected component (if applicable):

crash-6.0.4-2.el6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 11 errata-xmlrpc 2013-02-21 03:34:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0317.html