Bug 84146

Summary: Scanning PCI bus when no PCI present causes Signal 11
Product: [Retired] Red Hat Linux Reporter: Lee Olsen <lee>
Component: pciutilsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: notting, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-12 20:50:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
text file briefly describing bug identification and resolution none

Description Lee Olsen 2003-02-12 20:02:12 UTC
Description of problem:Signal 11 in /sbin/loader


Version-Release number of selected component (if applicable):


How reproducible:Attempt to install Redhat 7.3 on a system *WITHOUT* a PCI bus


Steps to Reproduce:
1.Make a boot floppy per the installation manual
2.boot non-PCI system from floppy
3.enter "linux dd" at "boot:" prompt
    
Actual results:Signal 11 from /sbin/loader


Expected results:Menu box requesting a driver disk


Additional info:Entering "linux nousb dd" delays the crash to after loading
additional drivers

Comment 1 Bill Nottingham 2003-02-12 20:03:55 UTC
Can you try this with the phoebe beta?

Comment 2 Lee Olsen 2003-02-12 20:17:40 UTC
Created attachment 90038 [details]
text file briefly describing bug identification and resolution

Since 8.0 is out, a patch against 7.3 probably doesn't make much sense.
I hope the function name, pci_scan_bus, the fact that it is a one line
function,
and the problem (methods is NULL) should make resolving this straight forward.
Enjoy
Lee

Comment 3 Bill Nottingham 2003-02-12 20:50:50 UTC
Fixed in 2.1.10-7, thanks!