Bug 841527

Summary: Get error after added several cartridges at the same time.
Product: OpenShift Origin Reporter: Mengjiao Gao <mgao>
Component: KubernetesAssignee: Dan McPherson <dmcphers>
Status: CLOSED DUPLICATE QA Contact: libra bugs <libra-bugs>
Severity: low Docs Contact:
Priority: low    
Version: 2.xCC: rmillner, szhou
Target Milestone: ---Keywords: Reopened, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-17 14:59:53 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Embed cartridges list.
none
Error when add metrics. none

Description Mengjiao Gao 2012-07-19 05:54:32 EDT
Description of problem:
During my testing, I tried to add three cartridges(cron-1.4,metric-0.1,mysql-5.1) at the same time. And they are all said created successfully with right get_started pages almost at the same time.
But when I checked cartridges added to the app, I found only cron-1.4 and metric-0.1 are there ,while mysql is not in the installed cartridges list. 
Then I tried to add mysql again , but encountered error message which said that "Embedded mysql-5.1 already attached to drupal"

Version-Release number of selected component (if applicable):
devenv_1902

How reproducible:
always

Steps to Reproduce:
1.Create a app.
2.Open three add cartridge page respectively with cartridge cron-1.4,metric-0.1,mysql-5.1
3.Click the "add cartridge" button in the three page at the same time.
  
Actual results:
Though the three cartridge get started page can show correctly, the installed cartridge list of the app does not contain all the three cartridge.

Expected results:
The three cartridge should be added well, and displayed in the installed cartridge list of the app correctly.
Additional info:
Comment 1 Clayton Coleman 2012-09-27 13:03:39 EDT
Can't repro - need more info.
Comment 2 Mengjiao Gao 2012-09-29 01:33:45 EDT
Created attachment 618843 [details]
Embed cartridges list.
Comment 3 Mengjiao Gao 2012-09-29 01:34:14 EDT
Created attachment 618844 [details]
Error when add metrics.
Comment 4 Mengjiao Gao 2012-09-29 01:40:27 EDT
I have tested this issue on devenv_2252. when I add cartridges "MongoDB 2.2""metrics 0.1 ""phpMyAdmin 3.4 "and "cron" at the same time, they all returned a page with successful embed message. But when I go to the application overview page, I only saw "MongoDB 2.2""phpMyAdmin 3.4 "and "cron" in the embed cartridge list(as the attachment #1 [details] shown). Then I tried to add "metrics 0.1" for another time, but just got a error message as the attachment #2 [details] shown.
So I will reopen this bug.
Comment 5 Clayton Coleman 2012-10-17 14:54:32 EDT
Some sort of race condition in the broker?
Comment 6 Dan McPherson 2012-10-17 14:57:55 EDT
Yes... Should be fixed with the model refactor.
Comment 7 Dan McPherson 2012-10-17 14:59:53 EDT
Duping on existing similar known race condition also waiting on the model refactor.

*** This bug has been marked as a duplicate of bug 855307 ***