Bug 843202

Summary: Please stop renaming the font
Product: [Fedora] Fedora Reporter: Benedikt Morbach <benedikt.morbach+fedora>
Component: linux-libertine-fontsAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: fonts-bugs, kevin, tagoh
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-09 22:48:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Benedikt Morbach 2012-07-25 22:01:55 UTC
In Fedora, the "main" font of this package is named "Linux Libertine".
Presumably through a fontconfig file.

If you run any other distribution (or OS) and download the fonts from upstream or somewhere else, they are named "Linux Libertine O".

This is bad, because for example Libreoffice will record the Fedora-only "Linux Libertine" and it will look wrong to others, even if they got the font.

I propose changing the name to "Linux Libertine O" and adding an alias for the old name, as not to break things for Fedora users.

I think the same applies to the Biolinum font, but I haven't checked that

(iirc this has been the case for all versions that I know)

Comment 1 Akira TAGOH 2012-07-26 04:57:00 UTC
In the latest version, 5.3.0, upstream takes that naming now. so this isn't a bug.

Comment 2 Nicolas Mailhot 2012-07-26 08:17:38 UTC
BTW it is totally normal that a Linux system will prefer the OTF variant, and that a windows system will prefer a TTF variant. So distros that do not map the linux-preferred name to the windows-preferred one when saving break compat with the bulk of libreoffice's users

And regardless of the name stored in documents, any good distro should alias the font names it does not ship to the font names it does ship, to provide transparent fallback to its users.

Comment 3 Benedikt Morbach 2012-07-26 09:45:05 UTC
(In reply to comment #1)
> In the latest version, 5.3.0, upstream takes that naming now. so this isn't
> a bug.

Sorry if I sound confused here, but I downloaded the OTF Version because I thought that is superior and should be used (the upstream website seems to suggest that), but the names are as I said.

(In reply to comment #2)

I agree that this is mainly a Windows <--> Linux problem, because I don't know a way to do font aliases on Windows.

LibreOffice (checked 3.5.5) ships a variant of this font, but it is called "Linux Libertine G".
This is incompatible with the Fedora naming, so users have to download the font from the website anyway, if they want to exchange documents.

Why exactly do you want TTF on Windows?
My impression was that OTF would support more features, such as smallcaps, alternates or ligatures (as seen here: http://www.linuxlibertine.org/index.php?id=87&L=1 ).
So I don't see a reason to prefer the TTF variant over the OTF variant.

I suggest to use the "Linux Libertine O" name for future releases.

Comment 4 Nicolas Mailhot 2012-07-26 10:22:31 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > In the latest version, 5.3.0, upstream takes that naming now. so this isn't
> > a bug.
> 
> Sorry if I sound confused here, but I downloaded the OTF Version because I
> thought that is superior and should be used (the upstream website seems to
> suggest that), but the names are as I said.

We should defintely use the otf variant on Linux

> (In reply to comment #2)
> 
> I agree that this is mainly a Windows <--> Linux problem, because I don't
> know a way to do font aliases on Windows.
> 
> LibreOffice (checked 3.5.5) ships a variant of this font, but it is called
> "Linux Libertine G".
> This is incompatible with the Fedora naming, so users have to download the
> font from the website anyway, if they want to exchange documents.

Then we should alias the G variant if we do not do it yet. That's a package bug

> Why exactly do you want TTF on Windows?
> My impression was that OTF would support more features

Those are OpenType properties not OTF properties. TTF and OTF are both OpenType containers nowadays.

Windows wants TTF container because it's the historical Windows font format and OTF is badly supported in at least older Windows versions

Comment 5 Nicolas Mailhot 2012-07-26 10:23:47 UTC
reopening as it seems some of the numerous font names libertine uses in the wild are not properly aliased Fedora-side 

(fontname G seems to be shipped with some libreoffice versions, no idea how much it differs from upstream)

Comment 6 Akira TAGOH 2012-07-26 10:32:39 UTC
(In reply to comment #3)
> Why exactly do you want TTF on Windows?
> My impression was that OTF would support more features, such as smallcaps,
> alternates or ligatures (as seen here:
> http://www.linuxlibertine.org/index.php?id=87&L=1 ).
> So I don't see a reason to prefer the TTF variant over the OTF variant.

just followed up on upstream's description to update the package:
“TTF” in file name
contains the fonts in MS TrueType-format. Best choice for use on screen.
“OTF” in file name
contains the fonts in Adobe OTF(CFF)-format. Best choice for printing. Perhaps best and smallest font format at all.

We could have both version of fonts in the package though, using different family name between displaying and printing sounds not a good idea. this would means people can't seamlessly print something out like what they see on their monitor. also we have a fallback rule for Linux Libertine O. even if you have any documents that created on the system that Linux Libertine O has, it should be displayed with Linux Libertine on Fedora.

Actually what you are proposing isn't so different at that point. just assuming one uses OTF version. so what if assuming one uses TTF version then?

Well, if we prefer OTF version, I could update with it but it looks like TTF version has been downloaded more than OTF version. so I assume "Linux Libertine" one is a bit major name around this font maybe.

Comment 7 Nicolas Mailhot 2012-07-26 12:02:36 UTC
> just followed up on upstream's description to update the package:
> “TTF” in file name
> contains the fonts in MS TrueType-format. Best choice for use on screen.
> “OTF” in file name
> contains the fonts in Adobe OTF(CFF)-format. Best choice for printing. Perhaps > best and smallest font format at all.

That's just an euphenism to say 'if you are under windows, use the TTF variant, if you are under any of the other systems with correct OTF support, use the OTF one) 

Just IMHO, of course, the difference between ITF and OTF are blurring away, and they are mostly equivalent nowadays feature-wise. What is not equivalent are TTF-oriented code stacks (common under windows) and PS-priented stacks (common for Adobe & Linux apps)

Comment 8 Akira TAGOH 2012-07-27 07:10:49 UTC
I see. anyway, updated fontconfig rules for more substitution on git:
http://pkgs.fedoraproject.org/gitweb/?p=linux-libertine-fonts.git

I'll also update the package with OTF then.

Comment 9 Nicolas Mailhot 2012-07-27 12:11:08 UTC
Just FYI: the G in the libreoffice variant means graphite, Libreoffice added graphite instructions to their libertine fork (because libreoffice does not support opentype properly yet, but SIL contributed graphite support)

However, it seems this work was not upstreamed so they are going to lag libertine changes. And as opentype support improves in libreoffice, the graphite extentions will matter less and less.

Comment 10 Fedora Update System 2012-07-31 08:50:06 UTC
linux-libertine-fonts-5.3.0-2.2012_07_02.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-11072/linux-libertine-fonts-5.3.0-2.2012_07_02.fc17

Comment 11 Fedora Update System 2012-07-31 08:58:50 UTC
linux-libertine-fonts-5.3.0-2.2012_07_02.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11030/linux-libertine-fonts-5.3.0-2.2012_07_02.fc16

Comment 12 Fedora Update System 2012-08-01 18:17:34 UTC
Package linux-libertine-fonts-5.3.0-2.2012_07_02.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-libertine-fonts-5.3.0-2.2012_07_02.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11030/linux-libertine-fonts-5.3.0-2.2012_07_02.fc16
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2012-08-09 22:48:22 UTC
linux-libertine-fonts-5.3.0-2.2012_07_02.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-08-09 23:15:01 UTC
linux-libertine-fonts-5.3.0-2.2012_07_02.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.