Bug 843275

Summary: tesseract package has not built for multiple Fedora releases
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: tesseractAssignee: Kevin Kofler <kevin>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: karlikt, kevin, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: tesseract-3.00-6.fc18 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-31 18:16:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713919    
Attachments:
Description Flags
patch to fix build failure none

Description Bill Nottingham 2012-07-25 18:14:00 EDT
This package has not been built since Fedora 15, having failed multiple mass
rebuild cycles.

As part of the normal process for retiring packages that have not
successfully built, this package is scheduled to be removed from Fedora on
or around the Fedora 18 branch date (August 7th).

Please fix this as soon as possible.
Comment 1 Tom Lane 2012-07-26 00:47:18 EDT
Created attachment 600435 [details]
patch to fix build failure

This patch is sufficient to make it build again.

I notice an awful lot of warnings about strict aliasing though.  It would likely be a good idea to add -fno-strict-aliasing to the build CFLAGS.
Comment 2 Kevin Kofler 2012-07-31 18:16:35 EDT
Fixed in tesseract-3.00-6.fc18.