Bug 84382

Summary: Installation stops after installing glibc
Product: [Retired] Red Hat Linux Reporter: Dennis Björklund <db>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED NOTABUG QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-15 09:43:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dennis Björklund 2003-02-15 07:41:06 UTC
I try to install Redhat 8.0 on an old computer (P90) with 32M memory and 800M
harddisk. I choose a custom installation and deselect all package groups. It
shows 478M to be installed which should fit nice on this small harddisk.

It starts to install fine, but when it comes to package glibc-2.2.93-5 the
progress bar goes up to 100% and after that nothing happens. I don't know if it
freezes at glibc or maybe at the next package to be installed (what ever that is).

I've waited 30 minutes just to be sure. It's a P90 after all. But nothing seems
to happen.

There is no error message or anything (not at the other virtual consoles
either). It has installed the files in glibc, I've checked that at the prompt

The glibc package has a post install script that runs
/usr/sbin/glibc_post_upgrade, I don't know what it does but I ran it in
/tmp/sysimage/usr/sbin just for fun and it terminates after 0.001s. It's
probably not stuck there.

The partition schema is 750M for / and 61M for swap. I've also tried with a 50M
/boot in the begining and 700M / but it's the same. The harddisk does not even
have 1024 cylinders so that should not be a problem.

When I run ps to see what's running I see nothing strange. There are 2 anaconda
processes running (or rather python2 of course).

The last thing in /root/install.log is just "Installing glibc-2.2.93-5" and
install.log.syslog is empty.

The CD media have been both tested and used to install 4 computers before
without problem.

That's all I can think of now that I can tell you. I which I had some more
information from the system but I don't.

Comment 1 Dennis Björklund 2003-02-15 09:43:06 UTC
Seems I needed more swap. I increased it to 128M and now it got passed that
point. It might be a good idea to add a check for that beforehand in anaconda.
All systems need glibc so 32M memory and 61M swap was obviously too little for rh8.

I don't know how to label this. NOTABUG I guess. I looked a little in the
install manual and all I could find was that it said that swap should be at lest
32M but I could not fins anything about memory needed. But maybe I just missed it.