Bug 84416

Summary: Mouse does not select through gnome-terminal
Product: [Retired] Red Hat Public Beta Reporter: Jim Cornette <jim.cornette>
Component: vteAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED WORKSFORME QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: jim.cornette, mitr, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-21 23:25:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jim Cornette 2003-02-16 10:48:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
I cannot use the mouse to slect functions through gnome-terminal. It resembles
more of a bitmap. No functions work through the mouse.
The function keys work fine.

I also checked out mc through xterm. mc works fine through xterm. It also works
fine during text mode.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Launch gnome-terminal
2.type mc to launch midnight commander
3.try clicking on the files or buttons, with the mouse. Three clicks inverts the
colors, still no functions.

Actual Results:  No actions were able to be initialized, when clicked upon.
Function keys worked fine.

Expected Results:  Expected the file or folder to be selected. Double clicking
expected opening of directories.

Additional info:

with straight Phoebe. The problem is there.
After upgrading to gnome-terminal-2.2.1-3, the bug was still present.

After upgrading to mc-4.6.0-1, the bug is still haunting the program.

Comment 1 Bill Nottingham 2003-02-17 21:37:06 UTC
What version of vte do you have installed?

Comment 2 Jim Cornette 2003-02-19 01:40:52 UTC
I upgraded from psyche to the second version of phoebe. The same problem is
present on both computers. You can select any function key, but you cannot click
on an item to activate menus, launch files or change directories.

Also, after exiting mc, the cursor seems to locate itself about 2 lines down the
gnome-terminal screen. It doesn't exit to the prompt.

If you change to the screen, while in mc, with the ctl-o combination works
alright. The prompt is located in the proper position. 

mc works properly within xterm or within a normal login screen.

The installed version of mc is 4.6.0-1

The installed version of gnome-terminal is 2.2.1-3

Comment 3 Jim Cornette 2003-02-19 01:46:30 UTC
Q: What version of vte do you have installed?

A: vte-0.10.12-1


Comment 4 Jim Cornette 2003-02-20 01:09:52 UTC
I installed vte-0.10.20-1 to see if any differences were noticed. The prompt was
still messed up upon exiting the screen. mc was still no more than a bitmap.
Clicking on any item still does not work.

Any more ideas as to what could cause this action?

Comment 5 Jim Cornette 2003-02-21 23:25:06 UTC
The problem went away with an upgrade to phoebe3.

Closing bug