Bug 844421

Summary: /dev/pts must always use the 'newinstance' mount flag to correctly support LXC
Product: Red Hat Enterprise Linux 6 Reporter: Giuseppe Ragusa <giuseppe.ragusa>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED DUPLICATE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.3CC: acathrow, ajia, arozansk, berrange, dallan, dyasny, dyuan, mzhan, rwu
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-25 05:42:49 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Giuseppe Ragusa 2012-07-30 10:34:27 EDT
Description of problem:
See Bugzilla #501718

I further note that to always correctly mount devpts as newinstance, maybe changes should be made to dracut (initial mount inside initramfs) and initscripts (rc.sysinit) packages too.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Daniel Berrange 2012-09-25 05:42:49 EDT
I don't know why this bug was opened against libvirt, because host OS setup is not within libvirt's realm of responsibility. This is either the kernel or base OS' job to fix.
Comment 4 Daniel Berrange 2012-09-25 05:48:01 EDT
FYI see the kernel bug 527483
Comment 5 Giuseppe Ragusa 2012-09-26 06:01:45 EDT
There's no public access to bug 527483 so please summarize your point here.

As for the libvirt affair, I actually opened this bug against kernel (after looking at discussion in bug 501718) and also noted that maybe changes were due in dracut and initscripts too.

Component was recently changed to libvirt by lwang@redhat.com

I supposed that changing kernel defaults could have (potentially) far reaching consequences (maybe inappropriate in RHEL), so I did not immediately reacted when component was switched to libvirt, since I understood it as an assumption that changing the devpts setup code in the LXC driver could be enough (maybe coupled with the aformementioned dracut/initscripts changes).
Comment 6 Daniel Berrange 2012-09-26 06:09:09 EDT
Sorry, I didn't notice that the kernel bug was private - it should not have been, so I made it public now. Libvirt already does the only thing I can do, which is to use 'newinstance' when creating the containers. The rest has to be done by the kernel or low level OS setup tools
Comment 7 Giuseppe Ragusa 2012-09-26 06:26:01 EDT
Thank you very much for your help/clarification.

I didn't read the libvirt code on this issue, so thank for clarifying this too.

Should I change this back to kernel (and reopen it) or should I open another one (hoping it does not get changed comnponent again)?

What do you think about the feasibility of such a kernel policy change in RHEL (the kernel reasoning in bug 501718 was for Fedora) vs. the multiple components approach (opening multiple bugs: for dracut and initscripts, since libvirt is already ok)?
Comment 8 Daniel Berrange 2012-09-26 06:30:50 EDT
No need to do anything with this bug, since we already have another one open against RHEL kernel to track it.

To be honest, I think the liklihood of this being fixed in the kernel in RHEL-6 lifetime is fairly low, because LXC in general is still lacking so many security related features, that this is low impact in the great scheme of things. In addition there is a quick workaround for people who do actually care - just edit /etc/fstab on their host to add the 'newinstance' flag against the /dev/pts entry and reboot.
Comment 9 Daniel Berrange 2012-09-26 06:36:30 EDT

*** This bug has been marked as a duplicate of bug 527483 ***