Bug 844502

Summary: qemu package doesn't build qemu-system-ppc(64)
Product: [Fedora] Fedora Reporter: Benjamin Herrenschmidt <benh>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aliguori, amit.shah, berrange, cfergeau, crobinso, dwmw2, itamar, knoel, pbonzini, rjones, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-14 16:37:00 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Benjamin Herrenschmidt 2012-07-30 19:08:51 EDT
Description of problem:

The qemu package in Fedora builds various qemu-system-xxx full system emulators but for some obscure reason doesn't build the ppc and ppc64 ones.

This is unfortunate for a couple of reasons:

 - qemu-system-ppc64 is a pre-requisite for kvm on ppc64

 - It's becoming a useful tool for developers without access to ppc64 server machines to be able to test, especially kernel changes.

Fedora doesn't use the official qemu upstream repository at this stage but uses the qemu-kvm one which at some point was having trouble building non-x86 targets. We have fixed this since then.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Benjamin Herrenschmidt 2012-07-30 19:22:50 EDT
Another pre-req: Bug #841403 so we get the slof firmware binary
Comment 2 Richard W.M. Jones 2012-07-31 03:17:28 EDT
https://lists.fedoraproject.org/pipermail/packaging/2012-July/008557.html

Read all the follow-ups too.
Comment 3 Benjamin Herrenschmidt 2012-07-31 03:40:27 EDT
Hi Richard !

I'm aware of this discussion :-) In fact we should post the above link
in bug #841403 (I'll do that now) which I was merely listing as a pre-req
for completeness.

The problem I filed this bug (here, ie 844502) for is the actual building
of qemu-system-ppc(64) itself which we can enable more or less independently of solving the firmware issues (it just won't be usable without the firmware).
Comment 4 Anthony Liguori 2012-08-01 18:21:39 EDT
To be clear, this bug just needs to add ppc64-softmmu to the target list in the spec file.
Comment 5 Benjamin Herrenschmidt 2012-08-01 19:09:07 EDT
And the new SLOF package as a dependency like the vgabios, seabios, etc...
Comment 6 Cole Robinson 2012-08-14 16:37:00 EDT
Should be fixed by qemu-1.2-0.2.20120806git3e430569.fc18