Bug 844535

Summary: Upgrade python-ZSI to remove the PyXML dep
Product: [Fedora] Fedora Reporter: Toshio Ernie Kuratomi <a.badger>
Component: python-ZSIAssignee: Tim Fenn <tim.fenn>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bkearney, tim.fenn
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-11 19:50:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 843176    

Description Toshio Ernie Kuratomi 2012-07-31 03:00:18 UTC
Description of problem:

For Fedora 18 we're looking to remove PyXML from the distribution https://fedoraproject.org/wiki/User:Toshio/Remove_PyXML

The reason is that PyXML has been dead upstream for a long time and the python stdlibrary has the dubious behaviour of replacing its xml module with the code in the PyXML package if PyXML is installed.  The combination of these two can break other libraries and applications that depend on the stdlib's xml module but instead are getting the older, buggier code from PyXML.

I've taken a look at the code in python-ZSI and much of it has fallbacks to code inside of python-ZSI if PyXML is not used.  However, some of the code may still fail if PyXML is not installed in the current version in Fedora (python-ZSI-2.0).  The python-ZSI-2.1a1 version from upstream has completely removed the need for PyXML so it would be safe to drop the dep if we were to upgrade to that release or a snapshot of their code.

Reading upstream's mailing lists, it seems that the upstream is active in fixing bugs but they do not currently have anyone who is interested in making release tarballs.  So if we want to benefit from the newer python-ZSI code we need to update to 2.1a1 or a snapshot.  I've checked Debian and Gentoo and it appears that both of those distros have already updated their packages to be based on 2.1a1 so it's not unreasonable for us to move to that version or beyond.

What do you think?

Comment 1 Tim Fenn 2012-07-31 04:18:09 UTC
Sure thing, sounds perfectly reasonable to me!  I'll make a package this weekend and submit it to rawhide, sound good?  (My only hesitation is that the package is listed as alpha, but it seems stable enough?)

Comment 2 Toshio Ernie Kuratomi 2012-07-31 05:55:42 UTC

Note that I don't use python-ZSI myself.  I just checked and found that other distros are shipping packages based on the 2.1a1 version.  Looking at the Debian version, they're only patching to remove shebang (#!) lines and remove the use of setuptools on install.  They're shipping 2.1a1 in all of their active versions.

Comment 3 Tim Fenn 2012-08-12 00:03:29 UTC
OK - I've made packages for rawhide and F18.  Give them a try and let me know it works for you?

Comment 4 Toshio Ernie Kuratomi 2012-08-17 17:44:45 UTC
Looks like the package still has the Requires: PyXML dep.

Comment 5 Tim Fenn 2012-08-19 01:18:16 UTC
(In reply to comment #4)
> Looks like the package still has the Requires: PyXML dep.

Oops, missed that.  it should be removed in 2.1-3.

Comment 6 Toshio Ernie Kuratomi 2012-08-21 16:26:37 UTC
Appears to work in light testing :-)  I don't have any code that uses this, though, so I just played around with the sample code.

Comment 7 Toshio Ernie Kuratomi 2013-01-11 19:50:24 UTC
Closing this as fixed in Rawhide.  Thanks!