Bug 845631

Summary: Fedora 17 freezes at boot with kernel 3.5
Product: [Fedora] Fedora Reporter: Timothy Davis <cpuobsessed>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 17CC: dyfet, eudemus, gansalmon, i.censo, itamar, jonathan, kernel-maint, madhu.chinakonda, nomankhn, ta.very.much.mate
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-14 14:01:51 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Timothy Davis 2012-08-03 12:15:42 EDT
Description of problem:
Updated my laptop to the latest kernel (3.5.0-2)
System freezes at this point:
fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
I have tried removing rhgb, quiet;adding vga=776 still freezes at same point
commented out 
        #set gfxpayload=keep
now the boot says something about vtimings

Version-Release number of selected component (if applicable):
3.5.0-2
Video is ATI X2300 mobility
hardware is HP Compaq 6910p
Core2Duo, 2Gb RAM, 80Gb HD; Fedora 17 is the only OS

How reproducible:
everytime

Steps to Reproduce:
1. Update kernel to 3.5.0-2
2. reboot
3.
  
Actual results:
system freezes

Expected results:
system boots

Additional info:
Comment 1 Timothy Davis 2012-08-03 14:22:06 EDT
I tried using nomodeset and all that did was use a resolution of 1024x768 and disable the vga port on the laptop
I booted an Ubuntu 12.10 live disc with 3.5 kernel and was able to use the vga port at least if put nomodeset on the kernel boot line.
Comment 2 Noman Khanzada 2012-08-05 15:16:08 EDT
I also face the same problem, then i add the option under kernel entry like that

################################################################################

menuentry 'Fedora, with Linux 3.5.0-2.fc17.i686.PAE' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.5.0-2.fc17.i686.PAE-advanced-134e7ced-5d4a-4785-92d9-a3de703fd08a' {
                load_video
                #set gfxpayload=keep
                set gfxmode=640x480
                set gfxpayload=1440x900x32
                insmod gzio
                insmod part_msdos
                insmod ext2
                insmod gfxterm
                insmod vbe
                set root='hd0,msdos1'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  1d09e080-a183-4cf1-add9-b69eea0d948d
                else
                  search --no-floppy --fs-uuid --set=root 1d09e080-a183-4cf1-add9-b69eea0d948d
                fi
                echo    'Loading Linux 3.5.0-2.fc17.i686.PAE ...'
                linux   /vmlinuz-3.5.0-2.fc17.i686.PAE root=UUID=134e7ced-5d4a-4785-92d9-a3de703fd08a ro nomodeset rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet

################################################################################

After that i am able to launch the kernel see below.

################################################################################

uname -ar
Linux server.example.com 3.5.0-2.fc17.i686.PAE #1 SMP Mon Jul 30 15:18:54 UTC 2012 i686 i686 i386 GNU/Linux
Comment 3 David Sugar 2012-08-06 04:16:09 EDT
I experienced the same problem, on a Dell D620 (Pentium-M with Intel video), with F17 and the new 3.5.0-2 kernel.  It simply freezes and the screen goes dead. The above suggestion did not seem to help at all.  It still only boots with 3.4.4 kernel.
Comment 4 Noman Khanzada 2012-08-06 15:31:07 EDT
@David send me your grub2.cfg file here.
Comment 5 David Sugar 2012-08-06 17:18:56 EDT
I think this issue is identical to 845388 "kernel-3.5.0-2.fc17.i686 doesn't boot on Dell Latitude D610", at least for me...


# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  10236c49-8476-46b9-9a53-9b5996572895
else
  search --no-floppy --fs-uuid --set=root 10236c49-8476-46b9-9a53-9b5996572895
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.5.0-2.fc17.i686)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-10236c49-8476-46b9-9a53-9b5996572895' {
	load_video
	# set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  10236c49-8476-46b9-9a53-9b5996572895
	else
	  search --no-floppy --fs-uuid --set=root 10236c49-8476-46b9-9a53-9b5996572895
	fi
	echo 'Loading Fedora (3.5.0-2.fc17.i686)'
	linux	/boot/vmlinuz-3.5.0-2.fc17.i686 root=UUID=10236c49-8476-46b9-9a53-9b5996572895 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
	echo 'Loading initial ramdisk ...'
	initrd /boot/initramfs-3.5.0-2.fc17.i686.img
}
menuentry 'Fedora (3.4.4-3.fc17.i686)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-10236c49-8476-46b9-9a53-9b5996572895' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  10236c49-8476-46b9-9a53-9b5996572895
	else
	  search --no-floppy --fs-uuid --set=root 10236c49-8476-46b9-9a53-9b5996572895
	fi
	echo 'Loading Fedora (3.4.4-3.fc17.i686)'
	linux	/boot/vmlinuz-3.4.4-3.fc17.i686 root=UUID=10236c49-8476-46b9-9a53-9b5996572895 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
	echo 'Loading initial ramdisk ...'
	initrd /boot/initramfs-3.4.4-3.fc17.i686.img
}
menuentry 'Fedora (3.4.3-1.fc17.i686)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-10236c49-8476-46b9-9a53-9b5996572895' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  10236c49-8476-46b9-9a53-9b5996572895
	else
	  search --no-floppy --fs-uuid --set=root 10236c49-8476-46b9-9a53-9b5996572895
	fi
	echo 'Loading Fedora (3.4.3-1.fc17.i686)'
	linux	/boot/vmlinuz-3.4.3-1.fc17.i686 root=UUID=10236c49-8476-46b9-9a53-9b5996572895 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
	echo 'Loading initial ramdisk ...'
	initrd /boot/initramfs-3.4.3-1.fc17.i686.img
}
submenu 'Advanced options for Fedora Linux' $menuentry_id_option 'gnulinux-advanced-10236c49-8476-46b9-9a53-9b5996572895' {
}
if [ "x$default" = 'Fedora Linux, with Linux 3.3.4-5.fc17.i686' ]; then default='Advanced options for Fedora Linux>Fedora Linux, with Linux 3.3.4-5.fc17.i686'; fi;
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_ppc_terminfo ###
### END /etc/grub.d/20_ppc_terminfo ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
Comment 6 Noman Khanzada 2012-08-08 11:29:44 EDT
Dear David,

Did you tried these options in kernel 3.5.0

                load_video
                #set gfxpayload=keep
                set gfxmode=640x480
                set gfxpayload=1440x900x32
                insmod gzio
                insmod part_msdos
                insmod ext2
                insmod gfxterm
                insmod vbe
Comment 7 D S 2012-08-08 18:58:04 EDT
Is there a business user howto that can guide me through the process?
Comment 8 David Sugar 2012-08-09 04:51:32 EDT
That did not seem to make any difference.
Comment 9 Timothy Davis 2012-08-09 08:57:47 EDT
I tried those changes as well (RV515 GPU) and I get this:
[drm] radeon kernel modesetting enabled
initializing kern modesetting
....
driver support precise vblank timestamp query
Comment 10 Timothy Davis 2012-08-09 09:03:22 EDT
(In reply to comment #9)
> I tried those changes as well (RV515 GPU) and I get this:
> [drm] radeon kernel modesetting enabled
> initializing kern modesetting
> ....
> driver support precise vblank timestamp query

however when I add nomodeset to the kernel line my highest resolution drops to 1024x768 (1280x800 is supported by the laptop)
Comment 11 Eudemus 2012-08-14 05:19:06 EDT
Is this still unresolved?

I also have a Dell Latitude D610, and although I can circumvent the issue by choosing an older kernel at the grub menu, that's obviously not the answer long-term (and it's annoying if I forget and it automatically chooses the most up-to-date kernel ..... and then, of course, hangs!).

Are there any logs that I should consult that might be recording what went wrong, and might give a clue as to how to fix it?

Cheers in anticipation.
Comment 12 Timothy Davis 2012-08-14 06:31:28 EDT
Kernel 3.5.1 did not fix it, adding the lines:
   set gfxpayload=640x480
   set gfxmode=1280x800x32
   ...
   insmod vbe
   insmod gfxterm


only causes this line:
    driver support precise vblank timestamp query
Comment 13 Dave Jones 2012-08-14 14:01:51 EDT

*** This bug has been marked as a duplicate of bug 845745 ***